Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a wireless broadband connection through a router and wireless modem. Everything works fine in Windows. However, in Ubuntu on the same machine, websites seem to take longer to start loading. I think the DNS lookup is slow. I think https sites may be slower, as I just can't log in to Gmail.

I am also using a mercurial repo with remote origin, and it takes forever (like 5 minutes) to push one small change. I think it is because it has to communicate through https multiple times. Should I change my DNS server? I've seen that I don't have these problems at my work network (they have another DNS server). This happens with the IPv4 settings being automatic (dhcp). When I change it to automatic (dhcp) addresses only, and add Google's 8.8.8.8 in the DNS servers, it still takes forever.

Why is this happening?

share|improve this question

migrated from serverfault.com Jan 13 '11 at 13:28

This question came from our site for professional system and network administrators.

add comment

4 Answers

Is your router giving you an IPv6 address even though it doesn't have external connectivity? Run ip addr and see if there's a "scope global" inet6 address. If there is, what could be happening is that whatever browser you're using is attempting an IPv6 lookup first, which fails, and then falls back to IPv4.

The quick fix in Firefox is to go to about:config in the address bar, and search for network.dns.disableipv6, which you can then set to true. However, if this is the problem, you're better off looking at your router to see why it's giving the IPv6 address if it can't use it.

share|improve this answer
add comment

since your using wireless it could be cause the ubuntu drivers for your device suck or some settings need to be changed. Try to access something via IP address instead to see if the problem persists or connect to your switch using a cord.

share|improve this answer
add comment

It's worth checking that your DNS server is getting set correctly. A very long time ago (2.2 Linux kernel) I found the default behaviour in the distro I was using at the time was to ignore the nameserver supplied via DHCP.

What nameserver gets setup under both OS? Have you verified that the details supplied in the DHCP response are getting used by the client? What timings do you get using dig/nslookup?

I think https sites may be slower

That implies it's nothing to do with DNS.

Have you tried enabling / disabling the TCP window scaling?

share|improve this answer
add comment

http://usingnix.wordpress.com/
http://usingnix.wordpress.com/2010/10/17/ubuntu-10-10-slow-internet/

Have a look at the above link, helped me to fix the issue of slow browsing.

Hope that Helps

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.