Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Windows 7 over a Windows XP installation (formatting my partition in the process). Now, when I boot, I get the "Windows Boot Manager" screen, asking me to choose between "Earlier Version of Windows" and "Windows 7." Choosing "Earlier Version of Windows" doesn't work (not that I'd want it to anyway), so how can I get rid of this screen altogether?

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

While Stanley's method works, it's only a workaround. Here's a guide how to actually delete the entry. I have one thing to add (in case you mess something up): Before you use the "bcedit /delete" command, use "bcedit /export" to backup your current Boot Manager config.

share|improve this answer
    
Ahh... I did not know how to get rid of it permanently. :) +1 for my thanks! –  Stanley Williams Jan 13 '11 at 16:54
    
Well, thanks back at you ;) –  Tobias Plutat Jan 13 '11 at 17:01
    
I'd recommend a GUI tool if you're paranoid about the command prompt - try EasyBCD. –  Shinrai Jan 13 '11 at 17:32
    
weird, bcdedit isn't recognized as a command... May have to try EasyBCD... –  bdukes Jan 13 '11 at 22:37
    
Hmmm, using Console2, I'm not able to see that command from any shell, but it works fine with a non-wrapped shell. Thanks! –  bdukes Jan 13 '11 at 23:12
add comment

Go to the "Run" prompt and type "msconfig" (without double quotes) In the next window, go to the Boot tab and check that there is only one option. Remove the unnecessary options. This should solve the problem. If it doesn't, take a peep into c:\boot.ini. However, take a backup of the file first in a safe location. Use this Microsoft URL for more help and info

share|improve this answer
    
MSConfig only shows the one Windows 7 option. I don't have a C:\boot.ini (I do have a D:\boot.ini, but I think that's just leftover from XP) –  bdukes Jan 13 '11 at 19:17
add comment
  1. Right Click "My Computer"
  2. Click Advanced
  3. Click Startup and Recovery
  4. Choose Default Operating System and Uncheck "Time To Display Operating Systems"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.