Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a small home network and recently I tried to enable remote desktop for one of the PC's. I have a mix of Windows 7, Windows Vista and XP runing alongside Ubuntu, centos and others (some virtual, some real). I have a few Windows 7 PC`s that can be connected to using remote desktop from inside and outside the network (port redirects on routers, etc, etc) and some XP ones.

The trouble is when I tried to do the same thing to a Windows 7 laptop I discovered I can't connect to it from another Windows 7 PC inside the home network. To sum it up

Working: XP --> Windows 7 not working: Windows 7 --> Windows 7

What I tried

  • disable and enable remote desktop (my computer -> remote settings)
  • removing and adding users to the remote settings window
  • adding a new user to the machine, administrator or 'normal' user
  • checking the firewall settings on the machine and set 'allow' to remote desktop for both 'home/work' and 'public' networks

Any tips on what should I do next? It displays ' .. secure connection' and after that the window with 'Your security credentials did not work' and it lets me try again with another user/password..

share|improve this question

It might be a firewall issue.

Check what you did against this article :
Configure Remote Desktop Access on Windows 7 Systems.

share|improve this answer
    
thank you, i already did all that... if it would be a firewall issue i wouldn't be able to connect from some pc's – vlad b. Jan 15 '11 at 10:31
    
1. So you are absolutely sure that Remote Desktop is allowed through Windows Firewall? 2. Do you connect using IP address or host name ? 3. Have you renamed any user account ? 4. Does the account have a password ? Also see this. – harrymc Jan 15 '11 at 11:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .