Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to use xcopy and it always returns with invalid drive specification

xcopy "C:\socp.tar" "\\FMDX1024\C\socp.tar"

FMDX1024 is a machine on the network.

any clue?

share|improve this question
    
Are you missing a colon off that second "C" –  Tog Jan 13 '11 at 19:39
    
It looks like you are trying to use the hidden admin share which is C$, unless you actually have shared a drive with the share name C. –  Scott McClenning Jan 13 '11 at 19:52

2 Answers 2

If I put in a valid path, XCOPY completes successfully for me.

If I purposely put in an invalid path, XCOPY returns, "Invalid drive specification".

So guessing what you think you have, you do not. Either the \\FMDX1024\ or C\ is incorrect (& it need not be "C\", it could be called anything).

C:\TMP>xcopy xxx.txt \\therube\c_drive\tmp\xxx.txt

C:xxx.txt

1 File(s) copied

C:\TMP>xcopy xxx.txt \\therube\c\tmp\xxx.txt

Invalid drive specification

0 File(s) copied

share|improve this answer

Maybe:

xcopy "C:\socp.tar" "\\FMDX1024\C$\socp.tar"

C$ is an Administrative share, which must be enabled by undoing Simple File Sharing.

See :
How to enable in Windows XP SP3
How to enable hidden administrative shares on XP Home edition

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.