Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What I want to use is the "-parallel" tcp or udp option from KVM / QEMU, but I don't seem to find any server for this client. I don't serve a printer but a hardware dongle.

I checked ser2net, which does provide "/dev/lp0" sharing, but it doesn't seem to work for KVM / QEMU. I suspect KVM / QEMU requires "/dev/parport0". I did rmmod lp, modprobe ppdev, linked ser2net to parport0, but it didn't work out. Perhaps ser2net is not suited for this.

I tried socat as well, and I tried netcat. No success.

Does anyone know any KVM / QEMU compatible parallel port server? Or did any of netcat, socat or ser2net work for you?

share|improve this question
    
If that "hardware dongle" is used in a licensing check, the software might include a latency check in order to defeat remote port sharing. –  Ben Voigt Jan 13 '11 at 23:10
    
Yes it is being used for copy-protection. Quite possible it contains a latency check. Still I'm wondering if KVM / QEMU parallel via network is supposed to work with ser2net. manpages are a bit short on examples. One annoying thing I noticed was that KVM doesn't reconnect TCP. So any change on the server side = reboot KVM :-( –  korkman Jan 14 '11 at 13:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.