Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my Core i5 desktop machine I tried to install windows 7 32 bit Ultimate. I received blue screen of death while installing OS. Earlier I had was 64 bit Windows vista which was working fine but now i cant install any of OS.

When I try to re-install OS again same error screen pops up? how can I fix this ? I have 4GB of RAM installed does it have problems with 32 bit OS.

When I install second OS I didn't reformat the entire hard disk.

share|improve this question
WHat's the error code on the BSOD ? – Sathya Jan 14 '11 at 4:08
Reduce the Ram to 2gb, see if installs, if it does, add the ram back after installation is complete. – Moab Jan 14 '11 at 15:50

32 bit Windows operating systems will only recognize the first 3gb of ram but having more won't hurt it.

Between 64 and 32 bit installs did you reformat and repartition the drive you're using for the install?

share|improve this answer
up vote 1 down vote accepted

I tried installing OS with external DVD drive I could install the Windwos 7 Ultimate 64 bit edition and it seems to work fine upto now. Some sort of fault in my DVD drive or the DVD drive doesn't recognize by windows OS setup is suspected.

share|improve this answer

The only time I've had BSoD errors during a Windows install was when there were third-party SCSI/RAID drivers that needed loading. I would not expect this for a Windows 7 install on a system that previously ran Vista, but it may be something to look up.

Other than that, the only things I've known likely to cause BSoDs since XP, which would also apply during the install process, are faulty hardware components. CPU, RAM, and Motherboard are the big three "usual suspects" in these cases.

share|improve this answer

Go into your BIOS and see if there is anything about "SATA Operation" or "SATA Mode." Change it to "ATA mode," if it is currently on "RAID" or "IRRT" mode. Once it's installed, try switching it back.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .