Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Does anyone know how to auto-set the read permissions for "World" upon upload of a file to Amazon S3 with Transmit? It is currently a two step process in my workflow:

  1. upload the file
  2. change permissions to allow the file to be read

I'd really to prefer to eliminate step 2 and just upload the file and have permissions set. Is there a way to create a profile that does this step for me?

share|improve this question

migrated from stackoverflow.com Jan 14 '11 at 11:34

This question came from our site for professional and enthusiast programmers.

closed as off topic by ChrisF, harrymc, Diago Jan 16 '11 at 15:16

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

up vote 6 down vote accepted

Go into the Preferences > Rules menu, and that can be set there. Not a AWS thing.

share|improve this answer
3  
I checked "Default File" and then chose Read: World in the S3 tab. –  louielouie Oct 31 '12 at 4:31
    
@LouieLouie has the answer. –  Andrew Nov 1 '12 at 13:44

Yes, you may use Bucket Policies to configure bucket in a way that all existing and new files will be publicly available.

Here is the bucket policy you need to apply:

{
  "Version": "2008-10-17",
  "Statement": [
    {
      "Sid": "AllowPublicRead",
      "Effect": "Allow",
      "Principal": {
        "AWS": "*"
      },
      "Action": [
        "s3:GetObject"
      ],
      "Resource": [
        "arn:aws:s3:::/*"
      ]
    }
  ]
}

You may use S3 Browser Freeware to apply Bucket Policy: http://s3browser.com/working-with-amazon-s3-bucket-policies.php

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.