Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer is unable to hibernate. When I start the computer and press any key, I'm instantly at the login screen.

I tried running powercfg -h on with no possitive effect.

The file hibernate.sys is not in my C: directory, and I can't restore it.

What could I do?

share|improve this question

migrated from stackoverflow.com Jan 14 '11 at 12:17

This question came from our site for professional and enthusiast programmers.

    
How is this a programming related question? –  Darin Dimitrov Jan 14 '11 at 10:15
    
sorry, dont know that this is only for programming –  ewggwegw Jan 14 '11 at 10:17
    
There is superuser.com where you might get better answers. –  Darin Dimitrov Jan 14 '11 at 10:18
    
Did hibernation previously work on this system? Is it actually showing enabled in the Power Options dialog? How much RAM is in your system - if 4 GB or greater, hibernation will not enable. –  Iszi Jan 14 '11 at 13:19
    
@Iszi: "if 4 GB or greater, hibernation will not enable" - that has not been true since about Windows XP SP2. And before that there was a hotfix for Windows XP to fix hibernate for systems over 2 GB (and to fix the problems with hibernate and fragmented RAM). –  Lawrence Dol Jan 14 '11 at 13:26
add comment

2 Answers

Have your enabled hibernation in Power Options (available in the Control Panel)?

In Windows XP that looks like:

alt text

share|improve this answer
add comment

Try to first disable the hibernation Then in the windows explorer window
Go to Tools>Folder Options > View>
Select 'show hidden folders' and uncheck 'hide system protected operating system files'
Now go to your c drive you should be able to see you hyberfil.sys and delete it too
Re-enable hibernation after these steps it should work.
(This problem usually occurs due to corrupted hyberfil.sys)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.