Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to permanently disable or remove Magnifier, Narrator, On-Screen Keyboard and High Contrast or at least permanently disable their keyboard shortcuts. I'm using Win7 inside a Parallels VM with an old IBM keyboard (SpaceSaver II) and USB/PS2 adaptor. Despite all my best efforts to customise the keyboard for the VM, the accessibility shortcuts activate almost by themselves at critical times :-(

Can anyone help?

share|improve this question
    
Can we assume you have trawled through the "Ease of Access" control panel to disable all of these features? –  Tog Jan 14 '11 at 14:33
    
I pretty much had, with the exception of the (less intuitive) ones under 'Make Keyboard Easier to Use' as per @Kyle 's post. –  5arx Jan 14 '11 at 15:50
1  
I wasn't needing this for the VM solution, but the answer provided saved me a ton of headache. –  Melikoth Mar 8 '12 at 16:19

4 Answers 4

up vote 4 down vote accepted

I searched for the shortcut keys you were talking about and found this. So I assume you are talking about filter keys? If so browse to 'Control Panel\All Control Panel Items\Ease of Access Center\Make the keyboard easier to use' there is options for turning filter keys off. As Tog said all the settings seem to revolve around the "Ease of Access center". If you want to see all options available in windows 7 create a new folder and rename it: Options.{ED7BA470-8E54-465E-825C-99712043E01C} The part before the "." (period) can be what ever you want I just figured "options" or settings makes sense.

share|improve this answer
    
Looking good, I had forgotten all about 'God Mode' ... I will mark your answer as 'Accepted' if, in five days time, I haven't had to look at the retro travesty that is Windows Magnifier ;-) –  5arx Jan 14 '11 at 15:47
1  
haha, I went in there just to look at the options when I was answering this and the stupid narrator auto-started and began announcing what I was looking at to the whole office... I hate the accessibility options I wish we could just uninstall them with add/remove like in xp. –  Kyle Jan 14 '11 at 15:51
1  
It would be nice if some of the settings available in here were just in the control panel like I would have expected. Solved my problem in about 30 seconds once I tried this. Thanks! –  Melikoth Mar 8 '12 at 16:18
    
My pleasure. And did Sir upvote the question ...? ;-) –  5arx Mar 8 '12 at 17:13

You can disable the tools on a per-user basis, or for all users. You just need modify the access-rights for the programs in the C:\Windows\System32 folder.

  • Magnify.exe
  • Narrator.exe
  • Osk.exe

To prevent a user from executing a file:

  1. Make yourself owner of the file.
    1. Open Properties dialog for the file.
    2. Select the Security tab.
    3. Click the Advanced button.
    4. Select the Owner tab.
    5. Click the Edit button.
    6. Select yourself in the list.
    7. Click the OK button.
    8. Close all the dialogs. (To update for the new owner)
  2. Make the user unable to execute the file.
    1. Open Properties dialogs for the file.
    2. Select the Security tab.
    3. Click the Advanced button.
    4. Select the Permissions tab. (Default)
    5. Click the Change permissions button.
    6. Click the Add button.
    7. Type the username, or find by clicking the Advanced button.
      • Alternatively, you could add Users for to disable them for everybody.
    8. On the row Traverse folder / execute file and row Deny, check the check-box.
    9. Click the OK button.
    10. Close all dialogs.

Now the keyboard-shortcuts won't do anything. At least not anything visible.

share|improve this answer

You can customize your W7 installation disc, remove the component completely

http://www.rt7lite.com/

share|improve this answer
    
Interesting. I'm not sure I want to do a full reinstall just to fix this issue though. Annoying though it is. –  5arx Jan 14 '11 at 15:49
    
I'll give him a +1 since this is the method for getting rid of the component completely. –  Kyle Jan 14 '11 at 16:40

Maybe you have accidentally turned on the 'Sticky Keys' feature of Windows 7, which messes with some of the modifier keys like the Windows Key. Press both SHIFT keys simultaneously to turn it off, maybe this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.