Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I misspell something in Visual Studio 10's find box (the one that shows in the editor's main window, not the popup window "Find and Replace" window), VS10 autocompletes to that misspelled word whenever I try fixing it. A Ctrl+Z will remove the entire autocompletion, including the last character I typed (which it can case change!). Backspacing and retyping will still autocomplete to the misspelled word. Only a cut and paste seems to work. Is there a way to disable this horrible feature!?

This is a picture of the find box that I am talking about:

enter image description here

share|improve this question
up vote 1 down vote accepted

I got a response from someone on the Microsoft forums about this. It cannot be disabled and the suggested work-arounds are not very useful. All I do is type in what I want and then hit the delete key to delete whatever is left highlighted.

The search box function changed a lot since VS 2008. In VS 2008, you clicked on it and the content of the box would be highlighted. Now you have to manually delete what is already in it before typing in a new search and pressing delete if needed to get rid of auto-completion text that you don't want... ever!

Dave

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .