Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Debian Squeeze currently installed on a Samsung N250 netbook with a Synaptics touchpad. These touchpads are, generally, good, and everything works perfectly on Windows.

The support is extremely sucky on Linux through. Of course it has all the cool features like two-finger scrolling, but the cursor (or whatever is a replacement for cursor when scrolling) is trembling awfully. It trembles when I just keep the finger on touchpad, it shakes awfully if the finger is close to the top of touchpad, and when I'm scrolling with it (no matter with two fingers or one), the page shakes a lot too. None of this behavior is observed even in Windows XP with just the default drivers installed.

Here's the Xorg version:

$ Xorg -version

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-686 i686 Debian
Current Operating System: Linux mannaz 2.6.32-5-686 #1 SMP Fri Dec 10 16:12:40 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-5-686 root=/dev/mapper/mannaz-root ro quiet splash
Build Date: 02 December 2010  01:08:37AM
xorg-server 2:1.7.7-10 (Julien Cristau <jcristau@debian.org>) 
Current version of pixman: 0.16.4

and here is synclient -l output: http://pastebin.com/Eqa6hGXP

share|improve this question
    
Maybe upgrading to the latest version of everything would help? I have one of those too and it works fine, as long as you're using the synaptics driver. –  Keith Jan 15 '11 at 6:53
    
@Keith, as of my experience, upgrading Debian from testing (squeeze) to unstable makes it pretty unstable, and the reverse process is hard if possible. Can you post your versions (and the synclient output) to compare them? –  whitequark Jan 15 '11 at 7:09
    
X.Org X Server 1.9.3.901 (1.9.4 RC 1) Release Date: 2011-01-07 X Protocol Version 11, Revision 0 Build Operating System: Linux 2.6.37-gentoo x86_64 Gentoo Current Operating System: Linux mercury 2.6.37-gentoo #4 SMP PREEMPT Sat Jan 15 05:48:18 PST 2011 x86_64 Kernel command line: root=/dev/ram0 real_root=/dev/mapper/isw_ciebjahfef_Volume05 ramdisk=8192 init=/linuxrc dodmraid udev enable_mtrr_cleanup mtrr_spare_reg_nr=1 Build Date: 15 January 2011 06:14:44AM and it's not unstable at all. Perhaps you should switch to Gentoo? –  Keith Jan 15 '11 at 14:28
    
@Keith I've had gentoo installed for half a year, and dumped it after re-merging firefox ~5 times in different ways to make eclipse work, no thanks. Can you also post your synclient/xinput settings somewhere? –  whitequark Jan 16 '11 at 18:10

1 Answer 1

up vote 0 down vote accepted

Assuming you are using a recent X server that supports udev and are using udev input driver. The most likely cause is that the synaptics is being used as a generic mouse. Try adding the following to your xorg.conf file.

Section "InputClass"
    Identifier "synaptics"
    MatchIsTouchpad "on"
    Driver "synaptics"
    Option "VertTwoFingerScroll" "on"

EndSection
share|improve this answer
    
All the interesting features of Synaptics, including two-finger scrolling, already work for me (and can be configured with synclient or gsynaptics). So I assume it's using the right driver. Also, this snippet is already included in my Xorg.conf anyway. –  whitequark Jan 18 '11 at 5:13
    
Well then, all I can say is It Works For Me. But then I'm using all newer drivers. –  Keith Jan 18 '11 at 5:20
    
OK, it works now (for a while, actually). Accepted for "recent X server". –  whitequark Sep 8 '11 at 5:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.