Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Okay, this problem has been plaguing this computer for a while now. We tried googling, and none of the answers found helped to solve the problem. So, I am now posting the answer here for posterity.

Office 2007 Home/Student edition was installed on the computer, running Vista (32-bit). One day, Word just up and stopped working. All the other programs continued to operate as expected. But every time you would click the icon for Word, it would pop up an install dialog, with a message reading "Preparing to install...". After a few minutes of the little progress bar going and going, it errors out, and gives error 1402, something to the effect of unable to access registry key HKEY_Local_Machine\Software\Classes\.wll\....

Searching around, every answer i found had to do with reassigning the permissions on this key, giving full rights to SYSTEM or to Everyone, and propagating the changes down to all sub-keys. When ever this was attempted though, it would tell us that we were unable to access the key due to permissions, even though we had run regedit as Administrator and are logged on with an administrative account.

We also tried uninstalling Office and reinstalling it, as well as doing a repair install. Both these attempts also threw the same 1402 error.

Also of note was that the executable for Word (winword.exe) was MIA and no longer to be found in the Office install directory.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Ultimately, despite everything that all the posts on google said, what ultimately was the solution to this problem was to simply delete the offending registry key instead of trying to change the permissions.

Once this was done, the installer was able to recreate them, and all is happy with the Office world again!

Although, I was kinda of surprised that it let me delete the keys even though it wouldn't let me change the permissions on them. Needless to say, numerous virus and malware scans have now been run

share|improve this answer
    
Please accept your own answer to close this question. –  user3463 Jan 15 '11 at 5:41
    
Still not able to until tomorrow. Little 48 hour limit on accepting your own answer. :) –  eidylon Jan 16 '11 at 1:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.