Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 on an ASUS machine. I have updated my Internet Explorer from 8 to 9 beta. Now I cannot open it. I'm double-clicking, but no IE window opens. What do I have to do to use Internet Explorer?

share|improve this question

closed as too localized by studiohack Nov 11 '11 at 16:33

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Make sure it is not already running under task manager (right click task bar and select "start task manager" and make sure that iexplore.exe does not appear there) If it does, select it and the press the end process button, and try again. If you want to uninstall it and try again you can go to control panel and click "view installed updates" in the left hand column and find internet explorer 9 in the list that appears. Good luck! –  Jay_Booney Jan 15 '11 at 10:50
@Jay - Your comment is good enough to be an answer. I would have given it a +1. –  Nifle Jan 15 '11 at 10:52
Beta versions of IE are not that easy to uninstall. They should only be installed on virtual machines or where Windows can be reinstalled. –  harrymc Jan 15 '11 at 13:20

Browse other questions tagged or ask your own question.