Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to setup a shared folder from the host (ubuntu 10.10) to mount on a virtualized CentOS 5.5 with Guest Additions (4.0.0) installed (Guest addition features are working ie. seamless mode etc.).

I am able to successfully mount the share with:

mount -t vboxsf -o rw,exec,uid=48,gid=48 sf_html /var/www/html/

(uid and guid belong to the apache user/group) the only problem is that once mounted and I try to write/create directories and files I get the following:

mkdir: cannot create directory `/var/www/html/test': Protocol error

I am using the proprietary version of VirtualBox version 4.0.0 r69151.

Has anyone had the same problem and been able to fix it or has any idea how to potentially fix this?

Another question, the reason for setting this up is this. Our production servers are on CentOS 5.5 however I am a great fan of Ubuntu and would like to develop on Ubuntu rather than CentOS. However in order to stay as close to the production environment I would like to virtualize CentOS to use a web server and use the shared folder as web root. Anyone know whether this isn't a good idea? Has anyone successfully been able to set this up?

Thanks guys, your help is always much appreciated and if you need any more information please let me know.

share|improve this question
up vote 1 down vote accepted

One problem I had with shared folders is the name of the folder had to be the same as the name of the share AND it must already exist. There might be some wacky permissions issue in your case, but I would try the making names match first thing...

share|improve this answer
Yep, you were right about the permissions. I was stupid enough to think that the user that started the vm had rw rights in the folder that was being shared. However when I actually checked I realised that the reason was simply that the user that ran the vm was unable to write to it. Doh.... thanks for you hint though – luxerama Jan 15 '11 at 18:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .