Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My plist file

<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN"
"http://www.apple.com/DTDs/PropertyList-1.0.dtd" >
<plist version='1.0'>
<dict>
<key>Label</key><string>org.macports.php-fpm</string>
<key>ProgramArguments</key>
<array>
    <string>/opt/local/bin/daemondo</string>
    <string>--label=php-fpm</string>
    <string>--start-cmd</string>
    <string>/opt/local/sbin/php-fpm</string>
    <string>;</string>
    <string>--pid=fileauto</string>
    <string>--pidfile</string>
    <string>/opt/local/var/run/php-fpm/php-fpm.pid</string>
</array>
<key>Debug</key><false/>
<key>Disabled</key><true/>
<key>OnDemand</key><false/>
</dict>
</plist>

After rebooting, it's not loading up automatically. I still have to manually start php-fpm. I have tried unloading and adding RunAtLoad etc. with no luck and tried both these launchctl commands.

sudo launchctl load -F /Library/LaunchDaemons/org.macports.php-fpm.plist
sudo launchctl load -w /Library/LaunchDaemons/org.macports.php-fpm.plist
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Try removing <key>Disabled</key><true/> AND adding <key>RunAtLoad</key><true/>.

share|improve this answer
    
Thanks that worked! I was using the Nginx plist file generated by macports as a template for this one and oddly enough nginx starts up on it's own even with the disabled key set as true. –  Seth Jan 16 '11 at 20:59
    
nginx' plist is probably activated with launchctl load -w ..., which'll permanently override the Disabled key -- but that's an unnecessarily complex and fragile way to do things. –  Gordon Davisson Jan 16 '11 at 21:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.