Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a very strange problem with my Mac lately. When I'm working in an app and a new window pane or sheet is displayed, sometimes it comes up completely white.

Once an app is having these problems, it will continue to bring up a blank screen for that particular window (although other windows work fine). After the app is relaunched, the window is fine again.

What I'm noticing that's very strange is that although the interface turns completely white, the functions of the interface are still available. So I have to "navigate blindly" around the interface, until I can relaunch.

This occurs throughout the operating system. Screenshots:

This is what happened when I tried opening the File menu in Lightroom app.

What happened to me on Lynda.com (in Firefox) after selecting the "Software..." dropdown. (All other dropdowns were fine. Reloading the page fixed it.)

When I was decompressing a file, The Unarchiver launched and opened this white window. It still decompressed the file.

This is what happened one time when I opened Finder (with TotalFinder) to my Downloads folder.

This is something I've never seen before. This just started happening lately. What could be the problem?

Thanks for your help.

NOTE: since new users are not allowed to post images, just image blank white interface elements. And since new users also aren't allowed to post more than one link, here's the first screenshot:

alt text

share|improve this question
    
Have you tried rebuilding your font cache? –  user3463 Jan 16 '11 at 5:33
    
I will do that now. Hopefully it works.. –  mr_schlomo Jan 16 '11 at 5:37
    
It's working so far. –  mr_schlomo Jan 16 '11 at 5:54
    
@Randolph Sounds like you can post that as an answer. –  Daniel Beck Jan 16 '11 at 8:11
    
Will do. It was a guess originally :-) –  user3463 Jan 16 '11 at 19:20
add comment

1 Answer 1

up vote 1 down vote accepted

I would suggest rebuilding the Font Cache.

To clear the current user's font cache, first quit all running applications (otherwise, you may see font oddities after using the command), then open Terminal (in Applications -> Utilities) and run this command:

$ atsutil databases -removeUser

If you want to remove the font cache for all users, use this command, and provide your admin password when asked:

$ sudo atsutil databases -remove

Once you’ve cleared the caches, you should stop and restart the ATS server with these commands:

$ atsutil server -shutdown

$ atsutil server -ping

It will take a second or two for the server to restart, but when it does, you should be good to go. If anything still looks odd, a logout and login should take care of any lingering issues.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.