Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have no items on my desktop in finder. When I enter the "ls" command in terminal at my desktop, two mysterious invisible files pop up:

~$Revised December EOM Report-2.xlsx

I've tried "sudo rm -rf "(both file names)", but still can't seem to remove them. I tried with and without quotes. I also tried the names without the ~$ prefix. Any ideas?

share|improve this question
up vote 3 down vote accepted

You need to escape the $ sign:

rm ~\$Revised_December_EOM_Report-2.xlsx

Alternatively, enable displaying hidden files in Finder by editing its defaults and delete from the GUI.

defaults write AppleShowAllFiles TRUE
killall Finder
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.