Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Asus K50IJ (Bestbuy) laptop and have issues with my sound. Speakers themselves work fine but when I plug into the headphone jack it auto mutes the front channel and no sounds comes out of either the speakers or the headphones. If I then unmute the channel I get sound from both the speakers and the headphones.

alsamixer shows the Headphone channel as all grayed out.

/etc/modprobe.d/alsa-base.conf I have tried snd-hda-intel model="asus-laptop" and snd-hda-intel model="asus"

In Sound Preferences I have gone to output and changed the Connector to 'Analog Headphones' that results in no sound from either speakers or headphones.

As one forum suggested I tried to comment out blacklist snd_pcsp in the blacklist.conf which resulted in no change.

lspci -v shows:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
    Subsystem: Santa Cruz Operation Device 1043
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at fe9f4000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel
    Capabilities: [130] Root Complex Link
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel
share|improve this question
add comment

2 Answers

The following thread might be pertinent :
Control both headphone and speaker volume from laptop (HP nc6000)

Simultaneously control the volume of both speakers and headphone simultaneously with the laptop's buttons

  • Right click on the Volume control (image) applet
  • Go in the Preferences menu
  • Hold down the Ctrl key, and click on both entries Main volume and Headphone to make them both highlighted.
  • Take note of the entry in the combo-box (mine is Intel 82801DB-ICH4 (Alsa mixer))
  • Press Close
  • Go in System -> Preferences -> Sound
  • On the last combo-box, select the same entry seen earlier (ie Intel 82801DB-ICH4 (Alsa mixer))
  • Hold down the Ctrl key, and click on both entries Main volume and Headphone to make them both highlighted.
  • Press Close

From there, if you press the buttons on the laptop to increase or decrease the volume, it will now affect both the speakers and the headphones

If this doesn't solve the problem, have a look also at this thread :
Sound from speaker and headphone - can't disable speaker

share|improve this answer
add comment

I have an Asus K50IJ (Bestbuy) laptop and have issues with my sound. Speakers themselves work fine but when I plug into the headphone jack it auto mutes the front channel and no sounds comes out of either the speakers or the headphones. If I then unmute the channel I get sound from both the speakers and the headphones.

I'm very sorry to tell you, but my laptop has the exact same issue on Windows. I tend to believe that the audio hardware doesn't allow us to play over two device connections simultaneously, and the only way to remedy this would be by a hardware mod. But that seems near impossible so you might be better off trying to connect a hardware mixer or a USB headset/headphone which would create a separate audio device which does allow you to play audio on both simultaneously...

My guess is that you could try to run Windows on your laptop to see if the same problem occurs there.

Realtek HDA here... From a DJing perspective this is a bad thing to discover. :-(

share|improve this answer
1  
Works fine in Windows 7 –  MrStatic Jan 24 '11 at 0:56
    
@MrStatic: Oh, then I guess it could be fixed... Sorry, can't help you further. :-( –  Tom Wijsman Jan 24 '11 at 1:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.