Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On windows 7 there's 'pause' and there's 'indexing speed is reduced due to user activity' but what if one wants full speed during desktop activity?

share|improve this question
    
In XP, I believe you could do this by accessing the indexing service utility. From MS documentation: 1.Open Computer Management (Local) 2.In the console tree, double-click Services and Applications. 3.Double-click Indexing Service. To open Computer Management, click Start, and then click Control Panel. Click Performance and Maintenance, click Administrative Tools, and then double-click Computer Management. –  Harv Jan 17 '11 at 18:28
    
And then what? You only click there. –  leladax Jan 19 '11 at 19:59
    
What is the indexing process' execution priority set to? –  cp2141 Jun 30 '11 at 13:48
    
By the way, for what is worth I noticed that it doesn't take more than 2 to 5 minutes for it to go to full speed so it's not a critical functionality to have in the first place. At least in Windows 8. –  leladax Mar 11 '13 at 18:00

5 Answers 5

up vote 11 down vote accepted

Summary from this page

  • limit what folders are indexed
  • update your Windows Search to version 4.0 (But only if Windows Updater hasn't already done)
  • HKLM\Software\Policies\Microsoft\Windows\Windows Search\DisableBackoff
    set the value to 1 if you are on a non-domain joined computer
  • on domain joined computer, edit your group policy and set Disable indexer backoff to enabled Computer Configuration\Windows Settings\Administrative Templates\Windows Components\Search

    DisableBackoff=1 in other words: Don't worry about system activity - just index and get it over with already!

share|improve this answer

Above registry "hack" in the first top rated answer only seems to apply to Windows search 4 in XP, not 7.

The correct path to the registry key is:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager

Furthermore, you have to change the permissions to allow the change, then restart the search service.

These are the instructions I found which worked:

  1. Start up the registry editor. Press Windows Logo Key+R, type in regedit, and press enter. Alternatively, if you don’t have a Windows Logo Key on your keyboard, click the start menu button, type in run, press enter, then type in regedit, and press enter once more.

  2. Find the key to change. In the folder view tree to the left, browse your way through to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager. Once you’re there (the Gathering Manager folder is selected in the tree), a whole bunch of keys will appear in the right-hand window. Find the one that’s called DisableBackOffOnUser.

    • This key is what it’s all about. It basically determines whether or not the indexing process should stop when the user’s doing something. There are other similar keys that you could edit to force the indexer to keep indexing even if you were playing Bioshock while ripping a DVD and little flames were coming from your processor, but that’s not really necessary, so we’ll just focus on this one key. Unfortunately, Vista won’t let you change the key’s value (if you try, it’ll let you down with: Error writing the value’s new contents.), even though we've been elevated to have administrator privileges. So, to get permission to change the key's value, you need to do the following.

  3. Click on the key, so that it’s selected. Go to the Edit menu and select Permissions. In the pop-up window, click the Advanced button. In the new pop-up window, select the Owner tab, then in the list below Change owner to:, select Administrators, then click the OK button on both pop-up windows to return to the registry editor.

  4. Now, we can double-click the key and change its value to 1 (one). Click OK and close the registry editor.

  5. Restart your computer (or just restart the Windows Search service if you know how), and the indexer will start indexing your stuff even while you’re working. In the about twenty minutes it took me to write this, Vista has indexed 46,000 files on my computer.

share|improve this answer

There is a setting in the group policy for the computer, so you don't have to manually edit the registry.

  • Open run dialog: Win+R
  • Type gpedit.msc and hit OK
  • Browse to Administrative Templates\Windows Components\Search
  • Select disable backoff, and set it to Enabled.

enter image description here

http://codingtrek.blogspot.com/2009/10/how-to-enable-backoff-for-t.html

share|improve this answer
1  
This is really a better method than editing the registry. –  alx9r Aug 31 '13 at 17:45

Go in the registry to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager\

and set the value of "DisableBackoff" to 1

Other interesting registry keys:

  • DisableBackOffNotificationOverride
  • DisableBackOffOnCPU
  • DisableBackOffOnIO
  • DisableBackOffOnNotifications
  • DisableBackOffOnUser
share|improve this answer

"Searchindexer.exe" in task manager (you may have to show processes from all users), you can set the priority for that program in there.

Right click on Searchindexer.exe, select Priority> Above Normal or High (never select "real time")

http://techblissonline.com/run-program-process-cpu-priority-windows-vista-xp/

The down side:

It could slow desktop performance or lock up the system if set to high of a priority, A restart of the system or kill the process will clear this setting.

You have to set this every time SearchIndexer loads.

.

Here is some software that can change the priority on a permanent basis, I wold not make a permanent change utill you have experimented with settings first, it could cause problems when booting if you choose a too high priority and set it permanently.

http://www.prnwatch.com/prio.html

.

share|improve this answer
    
I'm not sure the indexing service does its thing by changing its own process priority.. –  Harv Jan 17 '11 at 18:25
    
Not sure what the OP means by "Full Speed" either, just posted the only thing that could apply to the question, at least to me anyway. –  Moab Jan 17 '11 at 20:49
    
The question is clear, it does not mean priority. It means the opposite of 'it's reduced due to user activity' which is mentioned in the question. So stop blaming me. –  leladax Jan 19 '11 at 19:56
    
It is not to me, link to where I blamed you for anything. –  Moab Jan 19 '11 at 22:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.