Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Trust Speedshare Turbo Pro router, which is running on channel 6. I found that the wireless signal (and network performance) dramatically drops from my PDA (I can barely attach to the network, even if I set the PDA's energy settings to maximum wireless performance) when I even exit my room, and I don't have shielded walls or something like that. I can't even stream a SD video from my desktop (connected via LAN) to my laptop using WiFi, while via LAN it works fine.

I read that changing router's channel could improve performance due to interference reducing. I found that almost all wireless networks around here run on channels 6 and 11. I tried to go to my router's settings page to change channel, but I found that the combo box only allows me to select 6!! I'm not sure, but I may have been able in the past to change channel, though not to all of the available channels. A few minutes ago I tried a firmware upgrade, but it didn't solve my problem.

My question is

  1. Is it possible that my router is someway locked to its channel? I bought it on my own, I didn't receive it from my ISP
  2. Apart from boosting the antenna power to the maximum (which, by the way, increases the EM radiation my and my family's bodies absorb 24/7 and is little more environment-unfriendly), do you have any tips on getting high quality transmission up to 5 metres from the antenna?

Thank you

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You cannot change the channel if you are using the router in Turbo mode. ALSO the range is reduced. Is this your problem?

From the manual:

Turbo When enabled, 2 channels are used in parallel for double throughput. Limitations: Only works in combination with Turbo Pro series wireless products. Can be used only on channel 6. Range will be shorter.

share|improve this answer
    
Ha, you found the same thing I did. Who would have thought to read the manual... –  Kyle Jan 17 '11 at 14:24
    
Oh, yea... Looks like I was so attracted by this fancy word "Turbo" and possibly made a mess. This definitely solves my ranging problem –  djechelon Jan 17 '11 at 14:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.