Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Sager computer has been having a strange issue with the charging. For a long time it would be working perfectly as long as I was active on it. After I'd leave idle for a while it would suddenly decide it didn't want to use AC power anymore and would just discharge the battery until it shutdown because of low battery levels.

Was not a huge deal to me since I just sent it to standby when done with it and it worked fine.

Recently, however, it would not detect AC power while the battery was in. It ran from the battery just fine but until you powered it down, unplugged the battery, then plugged in the AC adapter it would not be on AC. In addition if I plug the battery back in after it's on AC power, it will see it but the battery won't charge though it can still discharge it. This is OS independent.

I tried both a replacement battery and a replacement AC adapter. Neither solved my issue. I'm fairly comfortable opening and servicing a laptop but I don't know where to start. I'd like to avoid replacing my system board if possible.

Any Ideas?

share|improve this question
1  
You might want to open it up just to check that the connection to the board isn't loose. If it's not the adapter or battery that is the next place to check. –  Kyle Jan 17 '11 at 19:30
    
@Kyle, I'm kind of confused though, because it will run off the battery by itself and the AC adapter by itself. Could a lose cable be the culprit? –  Jeff F. Jan 17 '11 at 19:32
1  
I ran into a similar issue with my girlfriend's Toshiba, would run fine, sometimes charge off of AC others not. Eventually she got the same issue with no charging. With hers it was the motherboard, but more specifically the charging portion of the motherboard; if I would flex it I could get charge so I tried looking for opens, shorts, burnt out caps, resistors, etc. re-flowed a ton of solder and nothing worked. I ended up getting a new motherboard. But, have a look first and see if anything jumps out at you. –  Dan M. Jan 17 '11 at 19:45
1  
It's a good starting point considering this issue is so odd... I was just taking a guess which is why I didn't post an answer. It may just be loose and not actually broken off. Plus looking at Dan's post a loose port may actually be the culprit. –  Kyle Jan 17 '11 at 19:45

2 Answers 2

up vote 5 down vote accepted

I've seen this before with a similar MoBo. Have you tried updating your bios? That fixed it for me.(I made an account because this took like 2 weeks for me to figure out)

share|improve this answer
    
@user63547 Actually, I have not, I will give it a try, thanks. –  Jeff F. Jan 17 '11 at 21:15
    
@user63547, Wow, you are my hero! I would have never guessed that flashing the bios would fix that problem! Thanks for taking time to post that. If you want a start I'll add 100 point bounty on to this. Just send me a message! –  Jeff F. Jan 17 '11 at 21:36

As I said in my answer to your last question, if swapping the battery and AC adapter hasn't solved the problem it's almost certainly the charging mechanism of the motherboard. As Dan M. says in the comments, it's probably worth looking around inside the machine to make sure nothing is loose (the design of these things can vary a LOT from vendor to vendor) but odds are it's something integrated to the board, so you're going to have to end up replacing the whole thing (unless you can see something that obviously needs to be resoldered or the like).

EDIT: Since we've discovered the true culprit here, let me just add that you should ALWAYS UPDATE FIRMWARE before you go to the extent of replacing hardware. Generally if you're not having a fluke problem, the manufacturer knows about it (even if they don't explicitly say "We have problem X, this will fix it!").

share|improve this answer
    
@Shinrai While I do appreciate you posting your help, I nearly ordered a new system board and clearly did not need it and would have wasted a few hundred $$! Please make sure you know what the solution is and not just recommend replacement especially when I said "I'd like to avoid replacing my system board if possible."! –  Jeff F. Jan 17 '11 at 21:38
    
@Jeff - Oh, wow, I'm honestly shocked that a BIOS update fixed this. Clearly a specific bug with this board - I was sort of operating under the assumption you'd checked that sort of thing out since you seem pretty savvy. (And obviously you'd never spend that kind of money unless you'd exhausted all your other options...nobody can be THAT dumb...) –  Shinrai Jan 17 '11 at 21:44
    
@Shinrai I can't believe I didn't think to do that myself too but a lot of times its the simple things that are missed as in this case :) The only reason I added the -1 is because I nearly payed for the new System Board and I don't wanna see anyone else have the same issue for such a simple fix! –  Jeff F. Jan 17 '11 at 21:47
    
@Jeff - This sort of thing is also one of many reasons to avoid boutique brand laptops. :) –  Shinrai Jan 17 '11 at 21:49
    
@Shinrai Actually, this is the best laptop I've had so far. Several years old and this is the first issue. My first laptop, a Toshiba, Died after a few months and had to be repaired under warranty 5 times. My Acer Puckered out after a few years as well. –  Jeff F. Jan 17 '11 at 21:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.