Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

when I access our intranet via https I get this "certificate error: navigation blocked" error in IE8 on Windows XP SP3. I can click Continue to this website (not recommended). but I use IE for automation testing so I have to avoid these extra clicks.

Any idea?

I tried

  • setting “Turn off the Security Settings Check feature” to enabled.
  • setting "Display Mixed Content" to enabled
  • lowering security levels to minimum
  • adding the web server address to trusted zone
share|improve this question
Don't know much about disabling it, but i found this, seems it is better to fix the real – Moab Jan 17 '11 at 22:52
Or you might be able to disable it with Group Policy for – Moab Jan 17 '11 at 22:54
@Moab: found it. Thank you. – Radek Jan 17 '11 at 22:57
You can accept your own answer, you get no points but it helps others, thanks for posting it. – Moab Jan 17 '11 at 23:07
up vote 3 down vote accepted

in IE

  1. Click Tools and select Internet Options
  2. Click the Security
  3. Select "Trusted Sites" icon and set the Security level to "Medium Low".
  4. Close all the Windows. Then open the browser.
share|improve this answer
Thanks Radek. What are the security implications of doing this? – Sid Aug 29 '11 at 21:15
That you won't be warned in any case .... Great for automation testing :-) Probably not so good for all users... – Radek Aug 29 '11 at 23:07
1. I tried all of the other internet options: advance tab, check server and certificate. 2. I also did vista regedit and HKEY Local MACHINE SOFTWARE and nothing worked. I used your _internet options advanced tab and uncheck warn about certificate address mismatch, and it worked first time! – user121238 Mar 4 '12 at 0:14

You shouldn't have to change the security settings for this.

That error message is because your IE is missing a security update, you can follow any of this solutions to fix this without having to change your security settings.

Option 1:

Visit, go to Security & Updates -> Microsoft Update, then click on "Custom". One of the options on the left-hand navigation pane should be "Software, Optional". Look for "Root Certificate Update" and install that update.

Option 2:

Go to, click on "STCA" under "PEM Format". The web browser should prompt you to save the file. Save the file in a folder you'll remember. Open that folder and double click on the file you just downloaded (the file is named "stca.crt" by default). A window should come up displaying the details of the certificate. Click on "Install Certificate" on the bottom of the window. The "Certificate Import Wizard" should start. Click "Next" and select "Place all certificates in the following store". Click "Browse" and select "Trusted Root Certification Authorities" and click "OK", then "Next", then "Finish".

Option 3:

Visit using Microsoft Internet Explorer (IE). Your root certificate should automatically be updated.

Option 4:

If users are part of a policy group, then the administrator can enable "Update Root Certificates" under the policy settings. Windows will then update the root certificates automatically.

Once any of the above options are completed, you should be able to utilize Trustwave SSL certificates without any issues.

share|improve this answer
This is not due to IE missing a security update. It is warning you that there is a mismatch between the url being navigating to and the cn / domain associated with the SSL (in an attempt to protect from going to say and getting a virus or giving them cc info). For example if I buy an SSL for my website, I would set the CN to this domain and navigating to would be fine, however if I was on the actual server and went to https://localhost:1234 I would get this error. Same would be true if I used the server's IP instead of the domain name. – Despertar Jul 18 '12 at 18:45
@Despertar We've already experienced this on our company with some clients and IE complaining about the exact same thing. In our case was due to security updates missing in IE. After running the update there was no error message. – Federico Giust Jul 19 '12 at 20:21

You must log in to answer this question.

protected by Community Apr 19 '12 at 13:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .