Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to add a network printer at, but halfway it when it asked for a driver, I cancelled it because I do not have the driver at hand.

Later when I try to add again, it tells me the port (, which is automatically specified as the same as the IP for the printer, is already in use and then suggest

Now, I cannot find the printer anywhere such that I can remove it and use back the same port. How should I do it?

Any ideas?


share|improve this question
If there is an entry for the printer in your Device Manager, uninstall it. Otherwise, I would think that a reboot would solve it. – Felix Dombek Jan 18 '11 at 1:27
Have you tried simply rebooting? – Kyle Jan 18 '11 at 1:27

1 Answer 1

up vote 0 down vote accepted

Try the following:

cscript prnport.vbs -d -r PortName

cscript prnport.vbs -d -r aaa.bbb.ccc.ddd

share|improve this answer
after much searching I finally found the "port" settings page at right click any printer > printer properties > ports. there, I can remove the ports..... – Jake Jan 18 '11 at 7:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.