Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install Vista in a virtual PC on Windows XP Pro. I have VPC have the Vista iso mounted. Somewhere during the beginning of the installation I get an error "no device driver were found. make sure that the installation media contains correct drivers then click OK".

I have the motherboard's driver CD in a physical CD drive which is mounted using VPC so if it's looking for drivers, I expect it to pick it from the CD but it's still complaining. The CD has a Vista folder which tells me it has Vista stuff on it.

So what on earth is the installation looking for and why doesn't it indicate which driver it's looking for? This is one ambiguous message. I have googled the same message and it seems it deals mostly with the cd/dvd drive but since I am not installing from a physical cd drive why is it having problems? It has already read part of the ISO by showing a Vista installation screens so why now it's complaining about a driver?

I tried the Browse button and had it point to different folders on the motherboard's driver CD but no success.

So any ideas?

share|improve this question
add comment

7 Answers

I am not sure what is wrong in your case, but all hardware should be virtualised in a VM and you should not need your original driver cd - ever.

Even when Windows is installed, you usually just install additions or addons that come with the VM software, but again, not drivers.

I would re do setup and choose a different hard drive setup or run the wizard again as I think you may be using incorrect / unsupported virtual hardware.

share|improve this answer
add comment

You could probably run in to this issue if you've created a scsi hdd in your virtual machine but then your motherboard drivers won't be of any help. You will need drivers supplied by your virtualization software.

The other problem I've heard about is faulty media. The installation is having trouble reading from your dvd and that's why you get that cryptic error message.

You said that it's a physical cd, try copying all of it to a folder on your hard drive to make sure that you can read everything from it. You can also create an image of the cd and try to install from that.

share|improve this answer
add comment
up vote 0 down vote accepted

I didn't choose Vista (or any OS) when I created the vm. I deleted what I had and chose Vista and it worked.

share|improve this answer
add comment

Is there any way that you can avoid this? Or does it just popup automatically?No device drivers were found error in vista installation can be solved by the boot sequence, make the boot sequence CD then HDD then Floppy. Check this for more information : http://forums.techarena.in/operating-systems/1088644.htm

share|improve this answer
add comment

During setup, I added the "Install or update virtual machine additions" feature and it released my original iso image and replaced it with a new iso image to install/update virtual machine additions. I just went to CD->release iso. Then, CD->Capture Iso Image and clicked on my original iso with my OS cd and it worked fine. Hope that helps.

share|improve this answer
add comment

I succeeded after I enabled hardware visualization support. Here's how:

  1. Make sure your motherboard and CPU both support Intel VT-x or AMD-V virtualization technology.
  2. Go to your BIOS and enable VT-x/AMD-V virtualization. On my Lenovo Thinkpad, this was in the Config > CPU section.
  3. Power off and reboot

After doing this, I successfully installed Windows 7 as a guest OS in Fedora 16.

share|improve this answer
add comment

Using VirtualBox with a Windows 7 guest, I was having this issue.

The resolution was to set all Storage items to use the SATA controller under

Settings > Storage
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.