Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a new MacBook Pro with Leopard OS. I had no problem connecting it to my wifi. I have a few windows pcs that each share a few folders within a windows work group I already had set up. I cannot seem to get the MBP to join the workgroup so that it can see the shared directorys.

share|improve this question

2 Answers 2

up vote 6 down vote accepted

Unfortunately, you forgot to tell us what operating systems the Windows machines are running. I'll give you my standard Mac-XP answer and also the extra work you need to do if any of your Windows machines are running Vista. This last bit isn't necessary in Win7. I'm going to assume you've already set up your Windows file/printer sharing correctly and the Windows machines have no issues sharing files between themselves. Presumably whatever firewalls are running on these machines are correctly configured to allow LAN traffic.

To successfully share between Windows and Mac, make sure you have created identical user accounts/passwords on all the machines. Example:

Mac - user is Alexis, password 1234 Windows - create a user Alexis, password 1234

Etc.

On the Mac, make sure you are using the SMB protocol and not AFP. You set your Windows Sharing up in System Preferences>Sharing. Make sure you've allowed File Sharing (SMB) in your Mac's Firewall (System Preferences>Security>Firewall).

If any of the Windows computers are XP Pro or Media Center, go to Control Panel>Folder Options>View and uncheck "use Simple File Sharing".

If any of the Windows computers are running Vista, you need to do a bit more work:

Vista Business/Ultimate only - Start Orb>Search box>type: secpol.msc When secpol.msc appears in Results above, right-click it and "run as administrator".

Click on "Local Policies" --> "Security Options"

Navigate to the policy "Network Security: LAN Manager authentication level" and double-click it to get its Properties. By default Windows Vista sets the policy to "NTVLM2 responses only". Use the drop-down arrow to change this to "LM and NTLM – use NTLMV2 session security if negotiated".

In Vista Home Premium, you won't have this tool so per MVP Steve Winograd, do:

Start Orb>Search box>type: regedit When regedit appears in the Results above, right-click it and "run as administrator"

Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  1. If it doesn't already exist, create a DWORD value named LmCompatibilityLevel
  2. Set the value to 1 and reboot.

My experience with Leopard (and I'm running the latest, 10.5.7) is that sometimes the Windows machines will not show up automatically in the Shared section of Finder. You can easily get to your shares by clicking in Finder's Go Menu>Connect to Server and putting in smb://name-of-windows-box.

share|improve this answer
    
Thanks I got 'em connected! –  onEnterFrame Jul 17 '09 at 4:33
    
I'm glad to hear it. Thanks for taking the time to let me know. –  Malke Jul 17 '09 at 20:54
    
That's one hell of a comprehensive answer! +1 from me. –  Tobias Plutat Apr 14 '11 at 18:31

You haven't specified any particular error message, so I will assume that you are asking how to get a mac to join a windows workgroup.

System Preferences --> Network --> Advanced and click on the WINS tab. Fill in the workgroup space, press OK, Apply

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.