Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 7, you can drag a maximised window from one monitor to the next by dragging the titlebar. However, Firefox 4 now places tabs in the title bar when it's maximised. This means that when I try and drag my Firefox window to the other monitor I end up dragging a tab instead of the whole Firefox window.

It's quite annoying, as I'm used to "flicking" Windows from one monitor to the next. Does anyone know a way to stop Firefox from using the title bar for tabs?

share|improve this question
    
leave feedback! ;) –  Jeshii Jan 18 '11 at 22:43
    
I figured I'd try to actually be helpful, so I downloaded 4 Beta 9, but it doesn't put the tabs in the titlebar when maximized. Did you have to set something to make it do that? Do you mean full screen mode? –  Jeshii Jan 18 '11 at 22:51
1  
I had left feedback already and mentioned it on their forum too. However, thought I'd put it on here too - and glad I did, as it's paid off! Thanks for that! :-) –  Dan Jan 19 '11 at 8:33

5 Answers 5

up vote 1 down vote accepted

This is what I installed to fix this annoying behavior. Many thanks to the author!

https://addons.mozilla.org/en-US/firefox/addon/extra-padding-when-maximize/

share|improve this answer

Figured something out! If you turn on the menu bar, the maximized tabs in title bar behavior will stop! I always have menu on by default so I didn't notice. Right click in the tabs, and turn on the menu bar (file, edit view etc) and this will give you back regular behavior. Hope that helps!

share|improve this answer

Or right-click on the "+" near the right of the tab bar and un-select "Tabs on Top" if you don't want the menu bar. It will put the tabs back under the address bar where they used to be, but you'll have your title bar back.

Neither is really ideal for me. Wish we could have tabs on top but with flicking enabled when maximized! That's probably not possible though...

share|improve this answer
    
If I right-click on the "+", then I just see my bookmarks - I don't see the option you describe. I'm using beta10 if that makes a difference. –  Dan Jan 31 '11 at 14:53

open configuration editor (about:config), locate following value: browser.tabs.drawInTitlebar and set it to false

share|improve this answer
    
This is exactly what I wanted from my search here today. Thanks! –  Lightness Races in Orbit Mar 30 '11 at 16:19

Either enabling the menu bar, or disabling tabs on top seems to be the only way. I wish we could get like 1 or 2 mm of title bar thats dragable with tabs still on top

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.