Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running an ubuntu lucid laptop on battery. I want to make my power last as long as possible. Aswell as the normal things like turn down screen brightness, and turn off wifi, I'm using powertop. It will sometimes tell me things, e.g.:

Suggestion: Enable USB autosuspend by pressing the U key

OK, I press the U key to do that.

However a few minutes later it will give me the same suggestion, it's as if it never enabled USB autosuspend the first time.

It does this for other things aswell, not just USB autosuspend. e.g. it'll give me this message frequently:

An audio device is active 100.0% of the time:
hwC0D1 LSI ID 1040 

 Q - Quit   R - Refresh   A - Turn HD audio powersave on 

Is there anything I can do to make these choices 'stick'? Or do I have some unfortunatle hardware that won't obey linux? (If so, is there any way to confirm this?)

share|improve this question

migrated from serverfault.com Jan 18 '11 at 21:58

This question came from our site for professional system and network administrators.

    
superuser.com ? –  pQd Apr 30 '10 at 9:51

1 Answer 1

What kind of devices do you have plugged into the usb ports? One or more of those devices may not like the 'autosuspend' setting and forces it back on... which would cause powertop to re-suggest it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.