Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

My windows chkdsk every boot. How to disable that?

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, CharlieRB, DragonLord, Brad Patton, davidgo Apr 20 '13 at 7:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4  
You need to fix the filesystem, not to disable the checks. Normally, the NTFS filesystem is rather reliable, being able to recover after unclean shutdowns and that kind of events. If you get chkdsk even after a clean shutdown/reboot, there's likely to be some corruption... Does it report any errors after doing the checks? –  grawity Jan 19 '11 at 11:02
    
@grawity There's nothing wrong with my filesystem. Chkdsk reports no error. –  Jader Dias Jan 19 '11 at 11:13
3  
DO A BACKUP OR BE SORRY! –  Jeff F. Jan 19 '11 at 16:11
    
@Jeff there is nothing to backup when everything is in the Source Control or in the Cloud. And everyone is working with this problem for months without surprises so far. –  Jader Dias Jan 19 '11 at 17:30
    
cool, as long as you have all your data secure. It's crazy how many people try to work on this kind of stuff then lose all their data! –  Jeff F. Jan 19 '11 at 17:54

4 Answers 4

Go to run type chkntfs n /x where n id the drive you want to disable diskcheck on.
Reboot

share|improve this answer
    
didn't work for me –  Jader Dias Feb 12 '11 at 21:00

This is most likely caused by a failure to unmount a volume when chkdsk was originally set to run - you now have what we call a "dirty" drive. There are a number of ways to fix this so here is what I'd do in this case:

Use the Registry Editor to check and change a value:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

Change the BootExecute entry from:

autocheck autochk * /.

To:

autocheck autochk *

Or do this:

Start → Run → bring up a Command Prompt by typing in “CMD” (make sure it is running elevated... i.e. as administrator) and type:

fsutil dirty query c:

Press Enter. This queries the drive, and more than likely it will tell you that it is dirty. Next, type:

CHKNTFS /X c:. 

Press Enter. The X tells Windows to NOT check that particular drive (c:) on the next reboot. At this time, manually reboot your computer, it should not do a Chkdsk and take you directly to Windows.

Once Windows has fully loaded, bring up another CMD prompt (elevated) and now you want to do a Chkdsk manually by typing:

Chkdsk /r c:

This should take you through 5 stages of the scan and will unset that dirty bit.

Reference:

http://webcache.googleusercontent.com/search?q=cache:NqA59St7iRQJ:social.answers.microsoft.com/Forums/en-US/w7hardware/thread/d64a8229-2950-4d21-839d-6991e30d4a1e+&cd=1&hl=en&ct=clnk&gl=us

There was an old issue with Windows 7 and Avira AV software, not sure if this applies to you, surely it has been fixed by now.

http://techblog.avira.com/2009/11/26/chkdsk-in-windows-7/en/

Viruses are also known to cause this condition. You may be infected.

Follow the order given below to properly disinfect your PC:

  1. Make a boot AV disc then boot from the disc and scan the hard drive, remove any infections it finds, I prefer the Kaspersky disc myself. The New 2010 Kaspersky disc can update the AV dat files if you are connected to the internet at the time of scan and is suggested to update before the scan.

    http://www.techmixer.com/free-bootable-antivirus-rescue-cds-download-list/

  2. Install free MBAM, run the program and go to the Update tab and update it, then go to the Scanner Tab and do a quick scan, select and remove anything it finds.

    http://download.cnet.com/Malwarebytes-Anti-Malware/3000-8022_4-10804572.html

  3. When MBAM is done install SAS free version, run a quick scan, remove what it automatically selects.

    http://www.superantispyware.com/download.html

These last two are not AV software like Norton - they are on-demand scanners that only scan for nasties when you run the program and will not interfere with your installed AV. They can be run daily or weekly to ensure you are not infected. Be sure you update them before each scan.

share|improve this answer

As grawity said, fix the problem. Since you say that chkdsk reports no errors, then your drive is probably on its last legs. Replace it now before it's too late.

share|improve this answer
    
It's new. Some other new computers in my office have the same problem. –  Jader Dias Jan 19 '11 at 11:51
    
RMA the drives because they're probably faulty. The only other option would be to do a full reformat and reinstall and see if that fixes it. –  MBraedley Jan 19 '11 at 12:30
    
the problem reappears after formatting and reinstalling windows –  Jader Dias Jan 19 '11 at 17:28
up vote 0 down vote accepted

Windows Update fixed my problem in February. It was before the Windows 7 SP1 update.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.