Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I try to enable or disable extensions in Firefox. It says "Restart Firefox to complete your changes". I press the restart button and it restarts. When it comes back up, the extension is unchanged. How do I fix this?

This isn't just one specific Add-on. I've tried disabling lots of add-ons at once. Some of them lose their icons and stop working, for one session, but they are still shown, with a "Disable" button, in Add-ons, and they come back fully when I restart Firefox.

If I go into safe mode, tell it to disable all extensions, and then disable them all manually, their functionality no longer exists, but the Add-ons still shows them with "Disable" buttons, but with many missing icons:

alt text

If I then disable an extension and restart, all the ones I disabled are back to normal enabled again.

Firefox 3.6.13 in Windows 7

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You can try the following methods:

  • Try Removing the Add-on via Safe Mode
  • Checkout Add/Remove Programs
  • Remove the Add-on Manually

Please read this article for more details.

If that doesn't help, uninstall Firefox completely (which deletes your whole profile and settings) and reinstall from scratch. That should solve the problem.

share|improve this answer
    
It's all Add-ons, not just one. –  endolith Jan 19 '11 at 17:23
    
Did you try to enable/disable them in Safe Mode? –  Mehper C. Palavuzlar Jan 19 '11 at 17:51
    
Yes, I disabled all of them in Safe Mode and the same thing happened. –  endolith Jan 19 '11 at 18:56
1  
Then I recommend you back up your bookmarks and make a clean install. –  Mehper C. Palavuzlar Jan 19 '11 at 19:08
1  
By clean install, I mean uninstalling Firefox completely (which deletes your whole profile and settings) and reinstalling from scratch. –  Mehper C. Palavuzlar Jan 19 '11 at 19:15

Make sure you haven't got more than one instance of Firefox running

share|improve this answer
    
There's only one instance –  endolith Jan 19 '11 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.