Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Clevo M760T laptop.

It used to run Ubuntu 10.10. I recently reformatted it to Fedora 14 and now the WiFi card does not work.

Here's the weird thing: The WiFi card has a light on the laptop's front panel that says if it's "enabled" (can be seen by the O/S, in Ubuntu I would have no wlan0 interface until I enabled it this way, and it wouldn't show on lspci as far as I remember).

The WiFi is enabled using the Fn+F11 combo. I know the F11 key works, as I can use the full screen in Firefox with it, and I know the Fn keys, as I can use the Fn+F5/F6 combo to alter the volume, etc. No matter what I try, I can't seem to be able to get that light on, or the card to appear in Fedora.

This may be unrelated to Fedora; maybe the card has broken, but it seems odd that that would happen right when I installed Fedora.

Annoyingly, I don't know what make / model of WiFi card it was so I don't know if it's related to kernel modules or something similar (and nothing showing for it in lspci). Just that it worked (including actually using it to go on the internet) in Ubuntu 10.10, and does not now in Fedora 14.

Does anyone have any ideas of where to begin debugging this?

share|improve this question
    
Had some progress. Found a ubuntu 10.10 cd in the bin (literally), and booting live from that the light works again. Its a realtek 8187B, and shows up on lsusb, not lspci. Now to get that working on fedora ! –  Sirex Jan 19 '11 at 19:25
    
Hmmm, looks like a kernel recompile is needed. :( –  Sirex Jan 19 '11 at 20:34
add comment

1 Answer

up vote 0 down vote accepted

I am posting an answer, as I've got this working now. I had to recompile the kernel to get the rtl8187 module into it. I don't know why Fedora doesn't enable this module by default, or if there's a better way to do this without the recompile. If anyone knows a better way please share it!

share|improve this answer
    
... when i disable it the entire os hangs witha kernel panic, but oh well ! –  Sirex Jan 24 '11 at 8:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.