Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lacie Rugged XL 1TB. I try to connect it via USB 2.0 to my computer with Windows 7 64 bit.

The Disk is running, I can hear it. The nice orange LED is on. But Windows does not even recognize it. It does not appear in the device manager and it does not appear in the Disk Management. 2 days ago my Dad tried it at his XP machine and it worked without problems.

I also tried to find it with diskpart, but it doesn't appear there either.

Any suggestions besides contacting lacie support?

share|improve this question
    
I assume you tried it on all the usb ports? Do other USB mass storage devices work on that PC? –  Moab Jan 20 '11 at 20:19
    
I tried the front and back ports, but it didnt work. My webcam, mouse, keyboard, usb-stick DO work. –  Exa Jan 20 '11 at 20:23
add comment

1 Answer

up vote 0 down vote accepted

Boot into your BIOS setup and make sure that the drive is listed there (assuming you have USB enabled in your BIOS).

This will help determine if it is your computer that is the problem or Windows.

Also, does it need external power? Make sure that is hooked up properly.

share|improve this answer
    
I will check the BIOS. Yeah it needs external power, but it's properly connected. I can even hear and feel it starting. It's running and has a normal light warm temperature. Gonna check the BIOS now. –  Exa Jan 20 '11 at 23:07
    
I couldn't find it in the BIOS. I found an additional SATA drive, of which I donÄt know what it is, but it said it has a size of 0 bytes. I don't think that this was the lacie drive, 'cause I connected it via USB and not SATA. I have no idea why this drive isnt't listed ANYWHERE. At least the drive manager should display it. 2 days ago it worked on an XP machine. Are there any known problems with this HD and Win7 x64? –  Exa Jan 21 '11 at 7:59
    
Since you couldn't find it in the BIOS, you confirmed that it is not a Windows problem. It is your computer in some way. It could be your ports, or your motherboard, or something that is not connecting the drive properly. Having said that, I'm a bit stumped as to why your computer wouldn't like that drive. Do you have other external HDD's you can test? Or even a thumb drive? –  th3dude Jan 21 '11 at 14:16
    
Lol. Just lol. I recently bought a new grapics card. ATI HD5850. Delivered today. I changed my old graphics card, with my new one. Booted my PC. Installing graphic drivers. Playin some games. After I will I turn the HD on, just for the fun of it... And my PC recognizes it! ô_O Problem solved, but I have no idea why. –  Exa Jan 22 '11 at 0:08
    
Very lol! I have no explanation for you, but I'm glad it works! –  th3dude Jan 22 '11 at 15:36
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.