Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In my Intel Core i5 2.80 GHz CPU , DH55HC series Intel mother board machine installed with windows 7 64 bit machine, when I right click my computer and see system properties I see that "Installed Memory(RAM): 4 GB(1.93 usable)".I have 2 x 2 GB DDR 3 RAM modules.

I have verified, * Two of RAM modules are working * Two of RAM slots in mother board are working

What are the cause(s) for this might be to look next ie: what settings in BIOS etc ?

share|improve this question

4 Answers 4

up vote 11 down vote accepted

This MS Support doc explains that...

On a computer that is running Windows 7, the usable memory (RAM) may be less than the installed memory.

This is expected behavior on computers that are running Windows 7. The reduction in available system memory depends on the configuration of the following:

  • The devices that are installed in the computer and the memory that is reserved by those devices
  • The ability of the motherboard to handle memory
  • The System BIOS version and settings
  • The version of Windows 7 that is installed (For example, Windows 7 Starter Edition only supports 2 GB of installed memory.)
  • Other system settings

For example, if you have a video card that has 256 MB of on-board memory, that memory must be mapped within the first 4 GB of address space. If 4 GB of system memory is already installed, part of that address space must be reserved by the graphics memory mapping. Graphics memory mapping overwrites a part of the system memory. These conditions reduce the total amount of system memory that is available to the operating system.

For more information about how to determine how memory is used on your computer, see the "Physical Memory Allocation in Windows 7" topic in the "More Information" section.

Things to try

Check the system configuration settings

This problem may occur because the Maximum memory option is selected incorrectly. To fix this, follow these steps:

  1. Click Start, type msconfig in the Search programs and files box, and then click msconfig in the Programs list.
  2. In the System Configuration window, click Advanced options on the Boot tab.
  3. Click to clear the Maximum memory check box, and then click OK.
  4. Restart the computer.

Update the system BIOS

Check BIOS settings

  • Enable the memory remapping feature
    Check the BIOS settings to see whether the memory remapping feature is enabled. Memory remapping gives Windows access to more memory. You can enable the memory remapping feature in the BIOS by booting to the system setup. See the User's Guide for your computer for instructions on how to boot to system setup on your computer. The name for the memory remapping feature may be different for different hardware vendors. This can be listed as memory remapping, memory extension, or something similar. Be aware that your computer may not support the memory remapping feature.

  • Change the AGP video aperture size in the BIOS settings
    Check the BIOS settings to see how much memory that you have allocated to AGP video aperture. This is the memory that the system is sharing with the video card that is used for texture mapping and rendering. This memory would not be used by the system, because it is locked by the video card. You can adjust the AGP video aperture size in the BIOS. Standard settings are "32MB,""64MB,""128MB,"and "Auto." After you change this setting in the BIOS, restart your computer, and then check the usable memory. You can test each setting to see which offers the best results.

Check possible issues with the physical RAM

The problem may occur because there are issues with the physical RAM installed.

  • Check whether you have bad memory modules
    To check whether you are experiencing this issue, turn off the computer, unplug the computer, and then swap the order of the memory.

  • Make sure that the memory arrangement is correct
    Refer to the User's Guide of the computer to determine in what order the memory modules should be inserted into the memory slots. The system may require you to use specific slots when you are not using all the available slots. For example, the computer has four slots available. But you may have to use slot 1 and slot 3 if you want to use only two memory modules.

  • Check whether memory standoff cards are used
    If you use a memory standoff card to hold multiple memory modules on the computer, the system may require specific configurations for this scenario. Therefore, the usable memory may be less than expected.

Three cheers for copying entire MS Support documents!

share|improve this answer
    
90% chance the correct solution is to enable memory remapping in the BIOS. That's definitely what you want to check first. –  David Schwartz Aug 29 '11 at 0:04

Some possible causes/suggestions:

  1. Make sure your RAM is seated properly in the right channel slots
  2. Did you just install your CPU as well? Some people report that a bent CPU pin or mis-seated CPU can cause this problem
  3. Boot your machine into the BIOS, are all 4gb reported as being there?
share|improve this answer
    
1.Make sure your RAM is seated properly in the right channel slots > Verified yes, removing eighther of RAM module also works fine 2.Did you just install your CPU as well? Some people report that a bent CPU pin or mis-seated CPU can cause this problem > "yes" 3.Boot your machine into the BIOS, are all 4gb reported as being there? > yes shows 4GB, no worries –  DSharper Jan 21 '11 at 16:58
    
@DSharper The memory is definitely seated as per page 37 of downloadmirror.intel.com/18506/eng/… , with 1 DIMM in each of the blue sockets? –  Mokubai Jan 21 '11 at 17:36
    
No bent pins on your CPU? Did you check? You can also try to just reseat it anyway. –  th3dude Jan 21 '11 at 18:03
    
Wouldn't a bent CPU pin make the whole thing not work? I was under the impression that 100% of them needs to be working all the time –  TheLQ Apr 10 '12 at 15:01

Are you sure it is an x64 machine? I had the same problem and found the answer here: http://msdn.microsoft.com/en-us/library/windows/desktop/aa366778%28v=vs.85%29.aspx#physical_memory_limits_windows_7

Windows 7 Starter has 2GB limit for x86 machines, and does not come in x64.

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Tom Wijsman Nov 11 '12 at 14:31

if not then check the answer from this page, seems you have to use slot 1 and 3 : http://www.tomshardware.com/forum/267407-30-usable

share|improve this answer
    
While that link may answer the question, it's preferrable to post the essential parts of the solution here and provide the link only for further reference. Otherwise, should the link become unavailable in the future, the answer becomes useless. –  Indrek Nov 3 '12 at 13:11

protected by Nifle Sep 7 '12 at 19:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.