Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use Apple Remote Desktop to access my computer at work. I forgot to give myself permissions via the gui and I am now trying to set it up via SSH. I've logged in to the computer and ran

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -users evan -privs -all -restart -agent -menu

based on what I found here.

The output of the command was

Starting...
Activated Remote Management.
Stopped ARD Agent.
Stopped VNC Server.
Stopped RFB Register MDNS
evan: Set user remote control privileges.
evan: Set user remote access.
Done.

Which lead me think it was set up properly and just to be safe I then ran

sudo reboot

However I'm still missing something. From home I am able to 'Observe' (the computer is currently at the login screen - hope that doesn't make a difference?) but when I try to 'Control' it says "You are not authorized to control this computer."

What simple mistake am I making?? :)

Thanks!!

share|improve this question
add comment

1 Answer

I would recommend double checking the settings when you're physically at the machine and make sure you have enabled Control.

You'll find it under the Sharing preference pane, under the Remote Management service. the -privs -all flags should have turned on control and observe, according to the man page and the online docs I have bookmarked.

You could always try setting it directly through kickstart again:

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -users evan -privs -ControlObserve

But I doubt it'll change much.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.