Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've met a rather annoying problem that should be very simple, but I can't seem to figure it out. I have a work laptop that is part of a domain, so my username is foobar\bob. I also have my home computer with no domain, just the username bob. I'm trying to connect to a share on my home computer from my work computer. It's asking me for my username and password, which is bob, but when I type in bob it assumes I mean foobar\bob, which of course doesn't work. I've tried to use hostname\bob, but that doesn't seem to work either...

What can I do here?

Both computers are running Windows 7.

share|improve this question
    
Do the "Bobs" have different passwords, or is it the same? –  Tobias Plutat Jan 22 '11 at 12:39
    
Does Win7 (on the remote PC) allow you to enable account logon auditing in secpol.msc? It might make things a little clearer. (Audit events go to Security log in eventvwr.msc.) –  grawity Jan 22 '11 at 14:45
    
It defaults to domain\bob but can you take out the domain part and try again? I connect from a domain computer to a non-domain computer regularly and this hasn't been an issue for me -- but I don't have Windows 7 so it's not exactly apples to apples. –  emgee Apr 7 '11 at 10:37
    
Have you checked the permissions on both the share and the folder itself? –  VolrathTheFallen Apr 7 '11 at 10:57

4 Answers 4

up vote 5 down vote accepted

I had the same problem. I was able to get around this by using the net use command. So basically, I just ran:

net use \\server\share password /USER:username

and then I browsed

\\server\share 

and it worked. username was just the username (no domain part or workgroup needed)

share|improve this answer
    
Smart. Will have to try that out the next time I need it :) –  Svish May 29 '11 at 20:51

I had this problem and solved it by setting up a homegroup from one of the computers. You do this when you connect to the network - you can go into network settings and click the link that says what type of network you selected. If you select Public like most do then you need to change to Home. You will need to do this from one machine on the network first. Then go into the settings and View/Print the password so you can connect other computers to the same homegroup. This solved my issue as I had the same problem - work computer on domain not allowed to change domain when logging into a networked computer. Homegroup solves this.

share|improve this answer

I've just had the same problem after re-installing Windows 7 on my laptop. All of the above answers work, but provide a temporary fix for the issue.

For a more permanent fix, select Control Panel -> HomeGroup, then click "Change Advanced Share Settings"

For the connection type you are using (or all of them), scroll down to "Homegroup Connections" setting, and change the value to "Use user accounts and passwords to connect to other computers"

From now on Windows will use whatever you enter in the logon prompt, rather than prefixing it with your domain name.

share|improve this answer

I had the same issue. I could ping the machine but not connect in Explorer. I was connecting to the other machine as a standard user. When I changed to an admin user (I mean admin on the machine I am connecting to not the machine I am connecting from) it worked by entering localhost\username

No idea why admin rights needed as I have lots of shared folders that are shared for Everyone not just admin.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.