Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My GNU/Linux PC (Debian Squeeze; called Iphigenie) gets its IP from a Thomson TG585v7 router. Network access works fine (web surfing, ssh client/server, etc). However querying for Iphigenie via DNS doesn't work (DNS for internet sites works). In contrast, the IPs of Windows machines can be resolved without problems via the TG585's DNS server.

I'm pretty sure it's a problem of the router not transferring the name from DHCP to DNS.[1] It's pretty interesting: the Linux PC shows up on the TG585's web interface, with proper name and all. Connecting to the router's telnet interface I can see that the PC gets a proper DHCP lease (10.0.0.9):

CPxxxxxxx=>dhcp server lease list  
Lease          Pool          TTL       State   Clientid  
3  10.0.0.18   LAN_private   13:48:08  USED    [01] 70:1a:04:xx:xx:xx
2  10.0.0.8    LAN_private   22:45:01  USED    [01] 00:21:6a:xx:xx:xx
0  10.0.0.9    LAN_private   infinite  USED    [01] 00:0e:35:xx:xx:xx
1  10.0.0.10   LAN_private   infinite  FREE    [01] 00:0f:b5:xx:xx:xx

However it doesn't show up in the DNS list, while the Windows machines do:

CP0852SF726=>dns server host list
Address          Hostname      TL (s)       Creator
<local>          dsldevice       1200     undefined
<local>          speedtouch      1200     undefined
10.0.0.8       * Elektra            0   DHCP_Server
10.0.0.18      * Reini-PC           0   DHCP_Server

If I use dns server host add name = Iphigenie addr=10.0.0.9 tls=0, then entry is added, but upon router reboot it becomes bogus (it then refers to the router itself).

I'm wondering what's the difference between the Linux box and the Windows machines, that the DHCP->DNS transfer works for the latter but not for the former?

Any suggestions?

[1] Evidence: ping Iphigenie works on the Linux PC (lookup via /etc/hosts), but fails on the Windows machines (lookup via DNS). DNS lookup for Iphigenie on the Linux machine also fails (host Iphigenie)

share|improve this question

1 Answer 1

I experienced the same problem, but between different systems running Debian Squeeze. Make sure your DHCP client is configured to send the host name. If using an interfaces(5) configuration with isc-dhcp-client, add the following to /etc/dhcp/dhclient.conf on Iphigenie:

send host-name "Iphigenie";

For some reason, adding the 'hostname' option in /etc/network/interfaces does not work.

Using wicd, ensure the "DHCP Hostname" option is checked, and the host name present in the properties for the connection.

share|improve this answer
    
I also found that any domain name containing more than one label (such as a fully‐qualified domain name) would not be served by the DNS server, even if using the domain name used by the router ('.config' on my BE‐provided router). The host name must be the unqualified host name, and a single label. –  Simon Ward Apr 17 '11 at 23:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.