Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed XAMPP on my sister's computer and I have no clue as to why apache and mysql won't start. I thought that it had to do with her firewall but I have turned it off and it still refuses to start up.

Have attached a screenshot of the error.

alt text

I have tried installing WAMP Server too and even that refused to start up.

Edit: The computer is running Windows 7

share|improve this question
    
For clarity: Which version of Windows is that? –  Tobias Plutat Jan 22 '11 at 13:24
    
@Tobias: The computer is running Windows 7 –  rzlines Jan 22 '11 at 13:31
    
Do you have administrator rights on the machine? You need to be an admin to start and stop services on Windows. –  Ian C. Jan 22 '11 at 13:37
    
Building on Ian's question: Does starting it without the SVC checkmark work? –  Tobias Plutat Jan 22 '11 at 13:41
    
@Ian: The XAMPP control invokes a UAC prompt when you install the service. –  Tobias Plutat Jan 22 '11 at 13:42

3 Answers 3

Apache has an error log. Look there for details.

share|improve this answer

My friend had the same problem. Most likely another program is using port 80. Run a Port-Check and find out what's using that port.

share|improve this answer
up vote 0 down vote accepted

After much ado that is after multiple re-installations, poking and probing through error logs and minutely studying the firewall, I decided that there must be something else that was wrong and hence I decided to check her hosts file (didn't expect it to be the worry as I didn't think she would have reached there) and there was the culprit. localhost was pointing to an IP that didn't exist in that network. Apparently, she had loaned out her PC for a few days to a friend and that's where it might have happened (well 'A Friend in Need is a Friend Indeed) ;)

Anyways deleting that entry that solved the problem, posting this answer as it solved the problem and just in case anyone over looks the hosts file being edited possibility.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.