Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install ruby-debug-ide on Snow Leopard running Ruby 1.9 so that I can debug ruby code in Netbeans.

I am using the following command

sudo gem install ruby-debug-ide19

However I keep getting the following error:

nathan:mark-moseley-ruby-debug-ide-9eb626b nathan$ sudo gem install ruby-debug-ide19

Building native extensions. This could take a while... ERROR: Error installing ruby-debug-ide19: ERROR: Failed to build gem native extension.

/Users/nathan/.rvm/rubies/ruby-1.9.2-head/bin/ruby extconf.rb
checking for vm_core.h... no
checking for vm_core.h... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
 --with-opt-dir
 --without-opt-dir
 --with-opt-include
 --without-opt-include=${opt-dir}/include
 --with-opt-lib
 --without-opt-lib=${opt-dir}/lib
 --with-make-prog
 --without-make-prog
 --srcdir=.
 --curdir
 --ruby=/Users/nathan/.rvm/rubies/ruby-1.9.2-head/bin/ruby
 --with-ruby-dir
 --without-ruby-dir
 --with-ruby-include
 --without-ruby-include=${ruby-dir}/include
 --with-ruby-lib
 --without-ruby-lib=${ruby-dir}/lib
/Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/contrib/uri_ext.rb:268:in `block (2 levels) in read': Looking for http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p160.tar.gz and all I got was a 404! (URI::NotFoundError)
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/1.9.1/net/http.rb:1194:in `block in transport_request'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/1.9.1/net/http.rb:2342:in `reading_body'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/1.9.1/net/http.rb:1193:in `transport_request'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/1.9.1/net/http.rb:1177:in `request'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/1.9.1/net/http.rb:1170:in `block in request'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/1.9.1/net/http.rb:627:in `start'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/1.9.1/net/http.rb:1168:in `request'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/contrib/uri_ext.rb:239:in `block in read'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/contrib/uri_ext.rb:286:in `connect'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/contrib/uri_ext.rb:234:in `read'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/contrib/uri_ext.rb:128:in `download'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby_core_source.rb:55:in `block in create_makefile_with_core'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/1.9.1/tempfile.rb:320:in `open'
 from /Users/nathan/.rvm/rubies/ruby-1.9.2-head/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby_core_source.rb:51:in `create_makefile_with_core'
 from extconf.rb:20:in `<main>'
Requesting http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p160.tar.gz


Gem files will remain installed in /Users/nathan/.rvm/gems/ruby-1.9.2-head/gems/linecache19-0.5.11 for inspection.
Results logged to /Users/nathan/.rvm/gems/ruby-1.9.2-head/gems/linecache19-0.5.11/ext/trace_nums/gem_make.out

Anyone know how I can get it installed?

Note I have the latest xcode installed but I installed Ruby 1.9 using RVM, which I also used to set it as the default ruby environment.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Solved it myself by installing Ruby using homebrew (brew install ruby). Seems the version RVM installs has some issues (I experienced the same thing with various gems).

I had to manually modify the symlinks after installing Ruby with homebrew as by default your system will still use Ruby 1.8 which comes with xcode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.