Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've seen similar problems, but this seems slightly unique, maybe...

I have a Gateway LT21 netbook, Win7.
I've upgraded RAM from 1gb to 2gb.
It didn't work.
So I updated to the latest Bios 1.25, then it worked. 2gb was recognized in the Bios and in Windows.
Every was fine.

Now today it seemed slow and, to my surprise, both the Bios and Win show only 1gb. :/
I've run memory diagnostic, no error.
I entered bios and hit Exit and Save. Still 1gb.
I took out the ram, put it back. Still 1gb. :/
CPU-Z shows 2048mb/2gb of RAM.

Further testing: if i put in the old 1gb ram, turn on, then put in the new 2gb ram again, the Bios and Win show 2gb of ram. BUT, once restarted at all (even from Bios) it seems to go back to showing incorrect 1gb ram again. :// (There are very few options in the bios, none appear memory-related.)

Any ideas?

share|improve this question
    
Do you have two sticks of 1GB, or one 2GB stick? (add @harrymc in your answer for me to get notified). –  harrymc Jan 23 '11 at 9:32
    
@harrymc It is one stick of 2GB –  Ael Feb 9 '11 at 16:31
    
I have, after this comment, added an answer below that doesn't depend on the stick(s). –  harrymc Feb 9 '11 at 16:46

2 Answers 2

Several such problems are listed in this Microsoft article :
The system memory that is reported in the System Information dialog box in Windows Vista is less than you expect if 4 GB of RAM is installed.

One of them in particular may be pertinent : You might make sure that Memory Remapping is enabled in the BIOS, in case memory and devices are taking the same memory address space, and the devices win. Remapping the devices moves them way out of the way of the memory, so you don't have the problem

share|improve this answer
    
The 1GB/2GB fits-in when booting with 1GB, the devices are allocated outside the 2GB address space. –  harrymc Feb 9 '11 at 19:43

Found this at http://www.tomshardware.com/forum/273962-30-gateway-lt21-series-netbook-upgrade-problem

I upgraded to 1.25 and it booted into Windows, but it only read as 1GB. To make a long story short, I flashed the BIOS several times to different versions, and found that BIOS version 1.24 loaded windows AND was recognized at 2.0GB. FINALLY! Hope this helps.

Hope this helps

BTW did you use the windows NAV50125.exe to flash your bios thru Windows? I can't seem to find any instruction on the windows method. How did it go? Did the program offer you a method to save the existing bios data before proceeding? TIA

share|improve this answer
    
I am on that thread :) Shortly after that post about 1.24, you'll see that i tried flashing the bios to 1.24 and had the same problem. They both work the 1st time, but once the system reboots the ram is 1GB again. Have you rebooted? It was a false success for the one who suggested it :/ I used windows flash method. I don't recall any options. Just run and it flashes. –  Ael Feb 9 '11 at 16:29
    
Sorry the 1.24 didn't work :( I ran the NAV50125.exe after stopping antivirus and some others. My heart was pounding on auto-reboot however everything appears to be fine. My google search criteria was nav50125.exe when I found your thread. I wanted to flash the bios for a "battery not charging to 100%" issue on my LT21 not the 2GB ram problem, I still only have the 1GB and by the looks of it may stick with the 1GB until this issue is resolved. BTW I haven't seen any change in my battery %, I'll know more after it's drained and recharged. I'll post back if I find out anything on the 2GB glitch. –  Brad Feb 10 '11 at 0:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.