Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm working on English (UK) version of Windows 7, my second input language is Russian. Since installation of Windows I have removed US keyboard layout and set LEFT ALT+SHIFT as input switcher.

Everything was fine until now. Recently I noticed that my switch combination does not always work. I opened language select bar and found there English (US) keyboard layout. I went to settings and found that in General Tab there is only two languages available, US was not listed. I decided to add US layout manually and remove it after. This operation went as expected, US layout disappeared from language bar. But after few hours it appeared again.

I started "googling" and found that I'm not alone. On Microsoft forum I found suggestion to remove US layout as I did before and than copy all settings to all profiles.

It's look like some service are adding US layout on it's own, but I have no idea which one.

Does any one know how to fix this issue?

share|improve this question
    
office has its own language preferences. did you check those settings? –  Pulkit Sinha Jan 22 '11 at 23:18
    
I'm not using MS Office –  Nazariy Jan 23 '11 at 0:37
    
I'm also getting this. For reference, two of the fruitless MS forum discussions are below. answers.microsoft.com/en-us/windows/forum/windows_7-desktop/… answers.microsoft.com/en-us/windows/forum/… –  Simon D Apr 23 '11 at 16:28
    
Which version of win 7 do you use? –  Michael K May 18 '11 at 11:02
    
I get the same behaviour in windows 8. –  Dorin Apr 5 '13 at 12:30
add comment

4 Answers

It seems that the English US keyboard layout will reappear when you run some programs that call for it specifically. I see certain ICQ versions often mentioned as an example by Russian users. Anyway, if you can narrow down what software is running when the US English layout comes back, you might be able to replace the culprit with software that doesn't have that problem (e.g. a different region's version or a different version number of the software or some third party alternative to it).

share|improve this answer
    
do you know any other way to stop that behaviour? –  Sebastian Godelet Dec 6 '13 at 22:06
    
Unfortunately I don't. –  rakslice Dec 6 '13 at 23:44
    
I think the biggest problem is that Microsoft tests their products with an English - US keyboard installed. I'm not sure if they are aware of that problem actually. –  Sebastian Godelet Dec 7 '13 at 8:48
add comment

It reappeared? Weird. Time to mess with the registry. This is what I would do.

Open Regedit Navigate to [HKEY_CURRENT_USER\Keyboard Layout\Preload]

Make sure the only string values present are 00000809 (english uk) and 00000419 (russian)

Right click on the preload key(folder) and change the permissions to deny full control to yourself and see if the problem reoccurs, if it does, deny some permissions to the other users since your program is using the other user to add the language. You should logoff/logon between changes to this key.

Goodluck

share|improve this answer
add comment

I've been having the same problem and I think I may have found a solution. Note that I've only tested this on one computer and so far this seems to be working.

First you need to install the US English layout and remove it again to make sure it's not set on your user account.

Go to Start->Run and type in

intl.cpl

First go to the "Keyboards and Languages" tab and click on "Change keyboards". This opens a new dialog where you should see a list of installed layouts but US English is most likely not listed.

You need to add the US keyboard by clicking on "Add...", find English (United States), open that and the underlying "Keyboard" by clicking on the + and there select the option "US". Click on "OK", this closes the window and you're back in the "Text Services and Input Languages" window.

Click on "Apply" to install the keyboard layout.

Then select the US English keyboard, click "Remove" and then "OK".

Now go to the "Administrative" tab and click on the "Copy settings" button. Now you should see locale settings for your current account, Welcome screen and new user accounts. It's very likely that the "Input language" value for "New user accounts" is set to "US English"

Under "Copy your current settings to:" select both "Welcome screen and system accounts" and "New user accounts". The values for both "Welcome screen" and "New user accounts" should change to your current settings.

Click on "OK" to confirm and again on "OK" to close the "Region and language" settings.

If this works for others and anyone feels like making a little more graphical version of this, feel free!

share|improve this answer
add comment

You might have Microsoft Office IME running on startup.

Open msconfig, switch to Startup tab and check if you have Microsoft Office IME entries:

msconfig screenshot

Disable those entries and restart your computer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.