Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've managed to mess up my Win + E shortcut, such that it gives me the following error message:

alt text

Is there any way to manually restore this shortcut?

I'm running Windows 7

share|improve this question
up vote 8 down vote accepted

What does WIN+E do?

Because troubleshooting System Internals is sweet...

Let's look on an untampered system with Process Monitor to see what exactly happens when we do that.

The steps I take:

  1. Download and run the program: http://live.sysinternals.com/procmon.exe
  2. Accept the EULA, reset the filters and filter anything away that's not interesting.
  3. Clean the log, press WIN+E and stop capturing afterwards.

This leaves me with a bunch of events (as the folder is being opened, etc...), so we look at the first ones: alt text

Note that we're only going to look at the SUCCES ones:

  • HKCU? No, current user configuration, too big key.
  • HKCU\Software\...\Explorer? No, explorer configuration, too big key.
  • C:\Windows\? No, read because it is the working directory
  • HKCU\Software\Classes? No, Windows classes, too big key, used to search the next one:
  • HKCR\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}? No, renaming this has no effect.
  • HKCR\Folder? BINGO!

Seems the contents of that key are way too specific regarding execution,
exploring that key, I would say opennewwindow would be the action WIN+E calls.

Just to verify it, let's adjust the value to Ivo Flipse.

Ouch, I just broke my computer... alt text BINGO!

How do I solve the problem?

If Ivo Flipse his problem isn't further along the call stack...

Set

HKEY_CLASSES_ROOT\Folder\shell\opennewwindow\command\DelegateExecute

to the default value:

{11dbb47c-a525-400b-9e80-a54615a090c0}

You might want to check the other keys under HKEY_CLASSES_ROOT\Folder\shell\,
they should have the same value as above...

share|improve this answer

I'd assume most likely it is virus corrupting the .exe file association. I have recently come over a fix of it (By jared: http://jaredheinrichs.com/wp-content/uploads/2009/11/vista-7-fixexe.txt )

Windows Registry Editor Version 5.00

[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithList]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithProgids]
"exefile"=hex(0):

save the above as a text file with .reg extension. Then double-click it.

share|improve this answer
    
Care to add what the easiest way to add these registry keys is? – Ivo Flipse Jan 23 '11 at 13:14
    
save the file as abc.reg, double click it. – bubu Jan 23 '11 at 14:02
2  
I was trying to tempt you into editing your question ;-) Anyway, I guess I'll have to restart for it to take effect, so I'll report back when I have – Ivo Flipse Jan 23 '11 at 14:06
    
The problem still occurs @bubu, even though I verified that the registry keys are created – Ivo Flipse Jan 24 '11 at 0:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .