Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have several network shares and created user accounts for the people who want to access them on my computer, so I can give every user different access rights.

My only problem is, these users are cluttering my login screen. I want my default user be selected automatically so I don't need to select a user from the login screen first every time I log in.

share|improve this question

4 Answers 4

up vote 6 down vote accepted

You need to remove the "interactive logon" right from the users. You can do this from the "Users and groups" node you get from right clicking on "Computer" in the start menu and choosing "Manage".

Unfortunately that too is not included on win7 Home premium or below - to achive the same thing on those editions you need to

1) Download the Windows 2003 resource tools 2) Use the "NTRights" command in that toolkit to (somewhat counter-intuitively) grant the "SeDenyInteractiveLogonRight":

ntrights.exe -u <username> +r SeDenyInteractiveLogonRight

That will stop the users from showing up on your login screen

share|improve this answer
  1. Run the Registry Editor (RegEdit.exe).

  2. Navigate to the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\
     CurrentVersion\Winlogon\SpecialAccounts\UserList
    
  3. Select UserList.

  4. In the right pane, right click on any blank space, and point to New -> DWORD (32-bit) Value.

  5. Name the new DWORD registry value name as the exact same name that match the name of the user account to be hidden. Double click on DWORD registry value, and set the value data to 0 in order to hide the account from Welcome Screen.

  6. Exit the registry editor and logoff or restart your computer to see it in effect.

Source: MyDigitalLife Article

share|improve this answer
    
This registry key does not exists on my installation of Windows 7 Ultimate x64. –  NTDLS Jan 10 '13 at 2:09
    
@NTDLS: Look in HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\... –  Tom Wijsman Jan 10 '13 at 12:40
    
I don't appear to have this key either, and a search on SpecialAccounts yielded nothing –  Maslow Mar 9 '13 at 13:58
3  
In my case, on my Windows 7 Ultimate 64 bit, I din't have to go to Wow6432Node, as when I did - it didn't work. Original solution works just fine. Note: I didn't have SpecialAccounts\UserList and had to create it manually! –  Ilia Rostovtsev Mar 16 '13 at 8:54

There is a much easier way. Open AdvancedUser Account window (same as safe login), and there highlight the user account and open property. Then you can choose other account type like backup operator or remote desktop user. See what happens. Bingo!

share|improve this answer

I am not sure If this will help anyone else but we had a very similar issue where an account was not showing up. it ended up that the user account was not in the users group for the local machine so the machine could not access the profile.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.