Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install Rockbox on my sansa e260 v2 because it's no longer working properly and I thought I might as well try Rockbox before chucking it out.

The problem is that I can charge it fully, but then it shuts down after some 10 minutes or so... Then it won't even open at all until I plug it back into the computer. The "low battery" message doesn't even show, it just looks dead.

Anyways, I got Rockbox Utility and double clicked. It opens up and I get this message: Configuration error: Your configuration is invalid. This is most likely due to a changed device path. The configuration dialog will now open to allow you to correct the problem. I click OK. I click Autodetect. I get this message: Fatal error: Unless you changed this installation will fail!

I don't understand this message at all! What does it mean? I thought maybe it had something to do with the USB mode.. Problem is, I can't find where to change USB mode on my player. I went through all the settings but I still can't find it. I'm not even sure this is really the problem.

So my question is, what do I do next?

BTW: My computer runs Ubuntu 10.04 LTS - the Lucid Lynx but I have a virtual machine with Windows 7 if that can be any help..

edit I think I can indicate to Rockbox Utility where my device is in the filesystem by using the browse button, effectively replacing the autodetect function, but I don't know where to find this information. I looked in the /media and /media/external folders but there's nothing in there. I can transfer songs fine through Rhythmbox, but I don't know where Rhythmbox found it..

I don't know if this can be any help: ->lsusb

->Bus 003 Device 004: ID 0781:7422 SanDisk Corp. Sansa E200 series v2 (mtp)

Notice it says MTP. I tried changing to MSC on the device, but I never found out how. I'm supposed to have a "USB Mode" option under "Settings", but I don't. Any idea why?

share|improve this question
add comment

1 Answer

You should be able to find it under /media after changing it from MTP to MSC.

share|improve this answer
    
@digitxp Thanks for the link. I have looked under "Settings" but the "USB Mode" option is nowhere to be found! –  Shawn Jan 24 '11 at 1:38
    
@Shawn I'm clueless. Anything even close to 'USB'? –  digitxp Jan 24 '11 at 23:18
    
@digitxp Nope: Here's every single option in settings menu: Music Options, Radio Options, Slideshow Options, Backlight, Language, Date & Time, Brightness, Volume, Reset All (tried that), Info, Auto Shut-Off, Format (tried that one too), Record Button, Press and Hold. –  Shawn Jan 25 '11 at 4:29
    
Apart from the Settings menu, I have these other menus: Music, FM Radio, Photo, Voice, Video. –  Shawn Jan 25 '11 at 4:36
    
Could be that your model doesn't support MSC. Unfortunately, now is the time to toss. –  digitxp Jan 25 '11 at 12:43
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.