Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a copy of Windows 7 as a "server" at my home. I have several file shares that I want to make available to specific users only.

I've modified the NTFS permissions to only allow these users to access their respective shares.

However, while a locally logged on user can access the actual folders just fine, over the network the remote access is authenticating as HomeGroupUser$ rather than the actual user in question, as shown by the Computer Management panel for shares. I do have matching user accounts (i.e. my username locally is abc and a parallel account with username abc and the same password exists on the server machine).

I don't want to disable homegroup because there are other shares where homegroup authentication would be desirable, especially for some people where they don't have a parallel account.

Is there a way to get the system to authenticate first by matching username, and then by homegroup authentication if there's no matching user?

share|improve this question

migrated from serverfault.com Jan 24 '11 at 2:56

This question came from our site for system and network administrators.

    
Feel free to migrate this to Super User if you think appropriate... this seemed like one of the "edge case" types of questions. –  David Pfeffer Jan 22 '11 at 21:42
    
Did you manage to make any progress on this? I am having the same exact issue. I have my HTPC running win 7 professional, and on it an application that uses windows authentication. My remote pcs are connecting as HTPC\HomeGroupUser$ instead of say NOTEBOOK\MyLocalUserName. This is throwing off the server application because although it does allow them to login, they all login as the same person! is there a way to fix this on the client so that it uses a different login instead of the homegroup one? –  Josh Feb 2 '11 at 22:46

1 Answer 1

up vote 2 down vote accepted

I ended up solving this by going into Network and Sharing Center -> Advanced Sharing Settings -> HomeGroup Connections (at the bottom) and changing it to use "Use user accounts and passwords to connect to other computers"

After doing this you have to make sure that all your other connected computers have to have matching users and passwords but once you do, you can login into one pc with another, and it will use the correct login (or prompt you for one if it doesn't match your credentials) instead of HomeGroupUser$

share|improve this answer
    
Excellent, thank you! That's exactly what it was. –  David Pfeffer Feb 6 '11 at 17:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.