Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an nVidia 8600GT card (made by EVGA) on a machine with Windows Vista (AMD Athlon X2 processors) and four gigs of ram. It runs pretty good, but I have had some slow/choppy/stuterring video playback issues whenever watching flash videos on Youtube or other sites. The problem is there with both Firefox and IE flash videos, but is maybe worse with Firefox. I also tried Linux with nVidia's binary drivers and it was about the same. I downloaded EVGA precision which allows me to control stuff like the fan and clock speed. The card's temp (in both Vista and Linux) is usually at 66C when idle (not playing a game or watching anything). It goes up a little when watching a video (maybe 68-72C).

Any ideas on how to fix this?

UPDATE: The issues are both with full screen and embedded flash videos. I have Flash (always make sure I use most recent for security), and the CPU is an AMD Athlon 64 X2 Dual Core Processor 4000+ at 2.11 GHZ. The current GPU driver installed is the most recent GeForce one from last July.

share|improve this question
I assume you have the latest drivers? – Ivo Flipse Aug 17 '09 at 14:18
Do you mean watching videos embedded, or full screen ? Because fullscreen is quite heavy, and easily "slow/choppy/stuterring", even on recent computers – Gnoupi Aug 17 '09 at 14:30
As counterintuitive as it sounds (and is), I've had video card manufacturers recently tell be to roll back one version on the drivers (it was an nVidia card, for a problem with World at War). Do you have a different (known good) video card you can try in the MoBo under consideration, to eliminate the MoBo and ancillaries as suspects? – Adrien Aug 17 '09 at 15:46
It has an integrated card, I suppose I could try going back to that – user5351 Aug 17 '09 at 16:05
Did the PC once have an ATi card in it? If so there may be a conflicting GART, try a Driver Cleaner. – kmarsh Aug 17 '09 at 18:49

Make sure you have the latest version of flash, not all versions support hardware acceleration. I think it starts at Flash

What type of CPU do you have? It's possible the bottleneck is not with the GPU.

share|improve this answer
If the CPU at 2.11 GHZ is the bottleneck, what are my options? – user5351 Aug 17 '09 at 15:02
If it's the CPU there isn't much you can do about it, except overclocking I reckon – Ivo Flipse Aug 17 '09 at 15:10
You have more than enough CPU, assuming your CPU is not broken. Have you run memtest86+ overnight? – kmarsh Aug 17 '09 at 15:11
I've had a CPU that's about that speed (single core) it didn't run flash very well at fullscreen but it ran fine normal size. Try to upgrade to the latest version of flash from Adobe that way you can take advantage of hardware acceleration if your flash version isn't doing it currently. – Grant Aug 17 '09 at 15:16
already using the most recent flash (See Update:) – user5351 Aug 17 '09 at 15:19

try and run the the flash WITHOUT hardware acceleration(right click on screen go to properties). this will put it in software rendering mode. something to do with NVIDIA's 8 series cards. Should be fixed with adobe flash player 10.1 beta with GPU acceleration.

share|improve this answer

Ok, I've struggled with this for a while. I only have the problem when on a high resolution (that's desktop area.) Also I have the problem anytime I have the graphics card is changing what's on my display. Ie. I could be running factorals and maxing my CPU and it'll play no problem, but if I scroll the audio gets choppy. I found the best way to test it is with Windows media player. When I have the visualization showing it's audio and video are choppy. But if I go to another tab or cover up the visualization (or even choose a simple visualization like "bars") the audio is smooth.

I fixed it by doing the following on Windows Vista. I'm not sure if all steps are neccesary but since I can't duplicate the problem anymore I can't narrow down which step fixed it. First I uninstalled and reinstalled my Nvidia graphics drivers. That didn't work. Then I opened the run window and type "msconfig". Disabled all non-microsoft services under the startup tab. Then rebooted. When it came back up I loaded a song in WMP with a crazy visualization running. It got choppy. I opened task manager, displayed processes from all users, then started ending processes. I don't recall which ones I ended first, and you can cause a BSOD so I wouldn't duplicate my steps here. Just go to the SVChost processes. I started ending the SVCHost ones listed as "mine" (my user account was listed under user name) then moved on to the once running under "local" after ending one of them I got an error that the system will have to be shutdown because a process unexpectedly terminated and media player immediatly stopped being choppy. I held down the windows key and tapped "r" to bring up the run box. Then typed "shutdown -a" to cancel the shutdown. (I don't know if the windows-r and shutdown cancel are neccesary.) I closed WMP and after that the system was pretty much locked up. I could open the start menu but no program would run. So I logged off. This locked up completely and I cold booted. When windows came back up the problem was gone.

It was wierd. I have no idea how that fixed it. In fact the computer "expert" in me can think of about a thousand reasons why that shouldn't have fixed it... but it did.

I wouldn't try this unless you have the exact same symptoms. Ie WMP's visualizations cause choppy audio and video not just flash player. One more point. I JUST did this. I yet don't know what other possible effects this had on my PC so this is a definate "do at your own risk."

Good luck.

share|improve this answer

What M/B chipset do you have? Have you installed, or looked for updated chipset drivers? There is a huge performance difference on nVidia and VIA chipsets between straight Windows and Windows with the chipset drivers installed.

share|improve this answer
I have the most recent drivers for my motherboard installed – user5351 Aug 17 '09 at 15:29

Something I've experienced with all of the flash-based video sites is that if, for whatever reason, you're not receiving the stream fast enough, you'll get chops and lags waiting for it to buffer the video. (In short, whatever mechanism flash uses for buffering sucks). I usually just let the entire video download before trying to play it.

share|improve this answer
The problem is still there even when the video downloads completely – user5351 Aug 17 '09 at 15:40
Didn't think it was likely, but it was worth a shot. – Adrien Aug 17 '09 at 15:48

make sure you have the correct drivers installed! since VIsta installs drivers automatically, wrong drivers might be installed for the Graphics driver! Uninstall the driver for graphics adapter installed by vista then install the drivers for the Geforce from the Driver CD given to you / find drivers supporting vista from manufacturers website/internet!

share|improve this answer

Some people report this as an interface problem between the GPU and the computer's memory, when the memory is too fast for the 8600GT.

The solution in this case was to reduce the RAM speed in the BIOS to 533 to solve these display problems.

share|improve this answer

Try this - Download and Install the latest driver from Nvidia. Right click on your desktop and select "Nvidia Control Panel", from the navigation tree in the "Select a Task" pane, click on "Video" and select "Adjust video image settings". To make the adjustments yourself, you should select "Use the NVIDIA settings". You can now make adjustments while playing a video. Try both settings "Edge enhancement and Noise reduction" and in the end, select "Use inverse telecine" as well.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.