Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Ubuntu Server in VirtualBox. When I select the internal network option for the network adapter and start up the VM, I only get IPv6 address. I need an IPv4 address as well. My host (running Windows 7) gets has both an IPv4 and IPv6 address listed when I run ipconfig. When I run ifconfig on the guest (running Ubuntu Server), it only lists IPv6. How can I fix this?

share|improve this question

4 Answers 4

Try running:

sudo ifup eth0

At the terminal's command line interface as the ubuntu user.

You might also want to check out the networking documentation, which does state that Virtualbox does not manage the 'internal network' option -- so, if you're wanting your virtual machine to talk to your host, you'll need to specify host-only networking, or bridged/NAT mode if you would like your VM to have the same network access as your VM Host.

share|improve this answer

Unlike IPv6, IPv4 does not have auto-configuration built-in; most of the time, DHCP is used. Try running dhclient eth0 or dhcpcd eth0 (depending on which Ubuntu comes with).

share|improve this answer

If your Windows 7 has an IP, does it looks like: ? If yes it's because Windows failed to get an IP with virtual box and used APIPA to get an IP address. (auto-attribution of IP address)

Also, if you want your VM to access your host the correct setup is "Host-only" network and not internal network.

Here's a link to virtualbox doc for these kind of configuration.

share|improve this answer

Make sure you are connecting your VM to right NIC on your Win7 machine. Had this happen when I bridged to the wired nic and then connected laptop via WiFi (different host nic)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.