Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to use VNC on OSX (client) to connect to a remote Linux machine. The problem is that I several important characters (such as braces, brackets, pipe and backslash) are in alt and alt-shift positions on my (Swedish) Mac-keyboard and that the alt-key is not handled as a shift (alt gr) key by linux but rather invokes command line editing commands.

All non-alted keys seem to be in the correct position so I have the same keyboard layout on the remote machine. But I would not want to have to bother, the preferred mode would be that the local keyboard layout on my client would determine what keys get sent.

I have tried several different VNC clients, and fiddled with settings, but not found anything that solves this.

share|improve this question
    
Fix the keyboard layout of the remote machine? –  Daniel Beck Jan 24 '11 at 18:35
    
If it was my private machine, yes, but this is a virtual machine used for testing and will be used by several people using different client environments. And it is also not the only such machine. Handconfiguring the keyboard layout of the remote machines could easily become a management hell. –  Simon Jan 25 '11 at 10:11
    
So now I've poked around and it seems that I can't get the alt/option and command keys to send anything but key code 64 (which maps to ALT_L as it happens). On one of the clients I've tried (JollysFastVNC), the right hand side keys sends nothing at all. Jollys and COTVNC have some kind of configuration for what physical key send what key code, but they don't seem to have any effect. And I've tried three different physical keyboards (Mac dito). –  Simon Jan 25 '11 at 11:08

2 Answers 2

Simon, in JollysFastVNC all you need is to press the right command key to toggle between local and distant interpretation of the alt/option key. When set to local, option-( will send a [, not alt-(.

share|improve this answer
    
Saved me some time! –  3molo Jan 24 '12 at 7:46

I ran into this same problem and just solved it by using the Google Chrome VNC Viewer: https://chrome.google.com/webstore/detail/vnc-viewer-for-google-chr/iabmpiboiopbgfabjmgeedhcmjenhbla/related

It worked straight away without any configuration whatsoever ({[]}) :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.