Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a software limit on Windows 7 Home Premium that stops you making over a certian number of local user accounts? I need to make up to 50 different user accounts on one PC.

How does Windows manage this? Obviously, it cannot show 50 different user profile pictures on the Welcome screen, so does it revert to the traditional two 'Username' and 'Password' fields?

share|improve this question
add comment

3 Answers 3

up vote 8 down vote accepted

In the interests of curiosity, I created 50 accounts on my Windows 7 Professional VM.

I used net user testx /add where x was a value between 1 and 50 (inclusive).

While I realise this is different to Home Premium, I can at least answer the second part of your question: it looks ridiculous.

This is on my Windows 7 Professional virtual machine running in VirtualBox: enter image description here

I imagine with the Local Policies you might be able to change the default login screen.

To change the login screen to show Ctrl + Alt + Del prompt, use netplwiz from an elevated command prompt, click on Advanced, and select "Require users to press Ctrl+Alt+Del".

Change login screen to Ctrl+Alt+Del

As @BloodPhilia has pointed out, you're only limited by resources, but I'd say if only two or three people are logged in at the same time, you'll be fine.

share|improve this answer
1  
I'd love to see a screenshot of that! –  BloodPhilia Jan 24 '11 at 22:59
1  
There you go. It looks silly. –  user3463 Jan 24 '11 at 23:09
1  
+1, awesome screenshot –  Moab Jan 24 '11 at 23:24
1  
Wow, thanks for taking the time to do that! I would hate to be the person at the end of the list, so looks like I'll have to find a way to enable the traditional login screen. –  Connor W Jan 25 '11 at 21:49
1  
I've modifed my answer to add how to change the login screen. –  user3463 Jan 25 '11 at 22:19
show 4 more comments

The number of accounts is not limited by software limitations. However, at a certain point you will run out of system resources to facilitate more user accounts.

Do take note of the fact that only 20 users at a time can connect to a network share that is located on that computer.

share|improve this answer
    
W7 upped it to 20....social.answers.microsoft.com/Forums/en-US/w7network/thread/… –  Moab Jan 24 '11 at 22:00
    
@Moab Didn't know, thanks! –  BloodPhilia Jan 24 '11 at 22:33
    
One of the few hidden perks in Windows 7 –  Moab Jan 24 '11 at 23:25
    
I assume though that as long as only one account is logged in at a time, having multiple accounts only eats up hard drive space and no other resources? Thanks for the info on networks shares too, quite handy to know. –  Connor W Jan 25 '11 at 21:51
    
@Connor Yes, true –  BloodPhilia Jan 25 '11 at 21:57
add comment

I know exactly what you were thinking. For more secured PC, users must type-in their usernames instead of just clicking the user profile on your screen then all the user have to do is to just type-in their password. In order to do that, you need to access your group policy editor. The steps are as follows:

  1. Type gpedit.msc on your search field from Your Windows Start menu. (Search programs and files)
  2. On your Local Group Policy Editor, under Local Computer policy, select Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\
  3. Search for "Interactive Logon: Do not display last user name".
  4. The seeting for this policy must be change or set to "Enabled"
  5. You will also notice below/next to that setting "Interactive Logon: Do not require Ctrl+Alt+Del" for more secured access, it must be changed or set to "Disabled"
  6. Close the Local Group Policy Editor and try to log-off.

Note:

  • In able to access your Local Group Policy Editor you must use an administrator account.
  • You must remember your username exactly in order to match the password. (Sometimes if users forgot to type-in the "complete" username it will result an error due to username mismatch)
  • If Settings does not effect. Try to restart the computer as well.

I really hope this could help!

share|improve this answer
1  
Not sure that actually answers the question… –  andrewdotnich Feb 5 '13 at 5:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.