Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install MikTex 2.9.3927 on Windows 7 x64. Very early in the installation process, I get a MikTex setup wizard error saying: "Windows API Error 2: The system cannot find the file specified Details: C:...\somefile.tpm"

The file that results in the error seems to be different every time I try. I have tried many different installation paths, with many different setup options. The same error occurs if I download the ~138MB "Basic MiKTeX 2.9" Installer or if I use the Net Installer to download the entire setup (~1GB).

Thanks for help in advance.

share|improve this question
    
I tried to install MikTeX 2.9 on a bare new W7 PC without any other software installed. I.e., there was no Adobe. I tried both paths. Did not work. It is certainly not Adobe's problem. –  user64624 Jan 31 '11 at 19:00
    
I installed 2.9 last night on Windows 7 with no problems. Today i'm trying to install on an XP machine and getting the "missing files" problems. Copying from my working version is not an option b/c i work in a "secure" area. Oh well ... now what?! –  user65528 Jan 31 '11 at 19:00

2 Answers 2

This is a known error with MikTex http://sourceforge.net/tracker/?func=detail&atid=110783&aid=3118717&group_id=10783

One proposed solution is to try to install to c:/MikTex/ but others say that doesn't work.

Another thread talks about a place to find the missing files http://sourceforge.net/projects/miktex/forums/forum/33790/topic/3455946

I might be able to help. I had the same problem at installing Miktex-Basic in a notebook with XP SP3. Most probable cause is a corrupted file. So, I downloaded (in my case) miktex-zzdb1-2.8.tar.lzma, miktex-zzdb2-2.8.tar.lzma and miktex-hunspell-bin-2.8.tar.lzma from a repository for instance: http://ftp.jaist.ac.jp/pub/CTAN/systems/win32/miktex/tm/packages/

I moved them to the installation sub-directory. Run again Miktex2.8 Net Installer and this time the installation went fine

Someone suggested it may be a conflict with adobe reader and could be resolved with a simple registry edit. http://entangled.wordpress.com/2009/09/18/installation-of-miktex-2-8-failed/#comment-1748

While there isn't a complete concensus try these three options here and see what works for you. If nothing else a google search for "Windows api error 2 minitex" yielded the most results.

share|improve this answer
    
Changing paths doesn't help. –  Eric Jan 24 '11 at 23:50
    
I have tried downloading the offending files. For example, I downloaded animate.tar.lzma. Then the installation crashed on a few different files, then it went back to animate. I ended up downloading that file and several other multiple times without getting out the the 'b's. (biblatex-nature was where I gave up) –  Eric Jan 24 '11 at 23:52
    
I uninstalled Adobe reader, all that accomplished is now I don't have a PDF reader. :-( –  Eric Jan 24 '11 at 23:53
    
My "solution" (which I do not consider to solve the problem) is that I installed Miktex 2.9 on Windows XP (SP3) with no issues, then copied the installation directory over to Windows 7. Apparently the installation does not use any critical registry entries, because running from the installation directory works fine on Windows 7. –  Eric Jan 25 '11 at 17:53
    
Eric, please choose the option "Answer my own question" and type up what you did to solve it. That way anyone else who stumbles upon this post will see the correct solution quickly, and it will close out the question. –  Daisetsu Jan 26 '11 at 22:38

I had the same problem with the x64 netinstaller on Windows 7. Running the installer as administrator in Windows 2008 Server compatibility mode fixed the problem for me (right-click the installer icon, choose "Properties" and click on the "Compatibility" tab).

share|improve this answer

protected by random Aug 19 '12 at 1:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.