Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been happily running perl programs on my Windows 7 PC for almost a year, and now suddenly they won't run without UAC intervention. When I give permission, they run in a new window, blink their output and close -- no chance to see anything.

I switched off auto updates some months ago (because they are too frequent, massive, and most importantly I was forever hitting new problems; and it seems ALL Windows updates are "important"(?), though very rarely actually apply to features which I use).

Anyway, the only software which I recently installed - knowingly - is for my Nokia phone. I've now uninstalled that software, and cold started, but the problem persists. (Apart from that, I have recently had problems with my Trend Micro Internet Security Pro slowing down the system, but Trend fixed that.)

I tried a "repair" installation of perl, but the problem persists. Anybody experienced same or similar, or have a clue about how to fix this?

share|improve this question

migrated from programmers.stackexchange.com Jan 24 '11 at 23:23

This question came from our site for professional programmers interested in conceptual questions about software development.

From Tech Republic:

Selectively disable UAC for your trusted Vista applications.

Takeaway:

Do you want to selectively disable User Account Control (UAC) for specific programs that run from Vista’s Start menu? You can — Greg Shultz shows you step by step using the Application Compatibility Toolkit.

Should work on Windows 7 also...

share|improve this answer
1  
Thanks for your help, studiohack. I was hoping for clues as to why Windows is suddenly behaving differently, without updates. I didn't previously mention that I do quite some work from "DOS" windows, and that's where I run perl programs, not from the Vista/Win7 Start menu - and btw I don't have this problem on my Vista PC. I like to have some control over my PCs, but Microsoft has different ideas about ownership rights and control, it seems, and apparently UAC was deliberately deisgned to annoy users ! and it does that successfully :( I'll try the AppCompatibility Toolkit. – Doug Jan 26 '11 at 19:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .