Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a laptop that will occasionally boot, but not often. Usually it locks shortly after starting the boot process. It does have diagnostics in it (in the cmos setup) which say the hard disk and memory are both ok. I've run the test multiple times without problem. However, almost all attempts to boot to the o/s on the hard disk (windows vista) result in a blank screen. the vista logo, load screen etc are never shown. I can't get a boot menu to let me choose to boot to safe mode. I tried various live disks, all of which result in the same thing. I tried booting to spin-rite (runs on free dos). spin rite locks most of the time, but once and a while I can actually get the software to come up .. .as soon as it starts to run the diagnostic, the computer locks hard. I've never been able to successfully run the software.

anyway, the bios setup software is the only thing that will actually run on the machine. anyone have an idea of what may be wrong? i would guess hard disk or memory, except those are the two tests I can actually run ... and both succeed every time.

tia, don

share|improve this question
Try a linux live disc to rule out all the hardware but the harddrive – prestomation Aug 17 '09 at 15:53
per the original message .. i did try various live disks - perhaps that wasn't clear - i tried several linux live distros. all suffer the same problem ... a blank screen after several seconds - sometimes i get a few linux boot messages. all lock < 5 seconds into the boot. thanks -don – Don Dickinson Aug 17 '09 at 17:46

I would check for signs of overheating. You could replace the thermal compound on the CPU fairly cheaply and see if that helps.

share|improve this answer
i'll try that i guess. the computer has been flawlessly running for months. just yesterday it locked up. since then it won't boot to anything. – Don Dickinson Aug 17 '09 at 19:27
You could try running with the side of the case off and have a large fan blowing into it. – prestomation Aug 17 '09 at 20:17

Use memtest+ on a linux live CD. I trust it more than that BIOS based versions. It isn't to say it is necessarily better or not, but it will give you an independent view of the memory to help rule it out as a problem.

Have you tried physcially disconnecting/removing the hard drive prior to booting one of your live discs? If the drive is broken in some glorious fashion, it could very well be causing a problem on the IDE/SATA bus when the more sophisticated OS drivers try to initialize and read data from it.

If the data on the drive is unimportant, you could also try to do a low level format on the drive and wipe it with all zeros (something along the lines of dd if=/dev/zero of=/dev/sda).

Best of luck.

share|improve this answer
good thought about removing the hard disk. i did that. the boot disk i used gave the same results however - near immediate lockups. i was able to get the spite rite recovery software bootdisk to work one time (it failed 5 or 6). its a good bootdisk to use because it boots to freedos (very small to load). anyway, it locked up shortly after running. thanks for the help. – Don Dickinson Aug 17 '09 at 19:26
up vote 0 down vote accepted

well. the thing is toast. not overheating, not disk, not memory. oh well. i bought a new one. thanks for the advice, though.


share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .